texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
williamoliver, Cday, JTHunts, 3fisherofmen, thumperthree
114677 Registered Users
Top Posters(All Time)
TexDawg 100,618
hopalong 94,363
Pilothawk 80,701
John175☮ 78,680
Bigbob_FTW 71,270
JDavis7873 67,401
Derek 🐝 66,116
Mark Perry 62,222
Forum Statistics
Forums61
Topics1,141,035
Posts15,588,956
Members139,676
Most Online36,273
Jan 23rd, 2013
Print Thread
Yamaha F70 Alarm #13837893 01/08/21 06:45 PM
Joined: Sep 2007
Posts: 989
J
Jamoke Offline OP
Pro Angler
OP Offline
Pro Angler
J
Joined: Sep 2007
Posts: 989
I have a 2011 Yamaha F70 (four stroke) that will have a steady alarm go off only when I am Idling or slow trolling and only after a long time. If I shut off and turn back on it will not come on for a while, it will also go away when I speed up. Appears to have a good pee stream, but I am thinking it might be the impeller/pump. I know the oil levels are fine and the water fuel separator is fine. Lower unit has been serviced with no changes. Any other Ideas would be appreciated.

Re: Yamaha F70 Alarm [Re: Jamoke] #13839025 01/09/21 02:27 PM
Joined: Mar 2010
Posts: 15,356
T Bird Online Content
TFF Guru
Online Content
TFF Guru
Joined: Mar 2010
Posts: 15,356
Could still be the impeller. When was it last changed?


[Linked Image]

USAF "Thunderbirds" Alumni 1985-1989

Okie by birth, Texan by choice.
Re: Yamaha F70 Alarm [Re: Jamoke] #13839751 01/10/21 12:04 AM
Joined: Sep 2007
Posts: 989
J
Jamoke Offline OP
Pro Angler
OP Offline
Pro Angler
J
Joined: Sep 2007
Posts: 989
That's what a friend said. Have it in the shop right now. Thanks

Previous Thread
Index
Next Thread

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3