texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Tim11, Richard Garison, Stephanie Sisk, BrockW08, Kruppa24
111523 Registered Users
Top Posters(All Time)
TexDawg 92,126
hopalong 82,377
Pilothawk 78,943
John175☮ 73,987
JDavis7873 67,397
Derek 🐝 63,233
Bigbob_FTW 60,431
Tritonman 58,793
Mark Perry 57,622
facebook
Forum Statistics
Forums60
Topics764,396
Posts9,615,593
Members111,523
Most Online36,273
Jan 23rd, 2013
Print Thread
Page 1 of 2 1 2
Mercury 2007 EFI 150 #13268662 09/03/19 01:35 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
The boat I bought was Nitro Z7 and I bought it from a guy I knew and thought I could trust, I test drove it and it ran good, then 2 days after I bought it I put it in the shop @Nautical Mile Marine in Flint, TX and they said carb and injectors were bad so I paid $4,000 for them to clean all injectors and carb.
So the problem is still occurring I have to choke my motor every time I crank it and when I put the throttle in gear to get on pad it lunges 4-5 times and then takes off but when I kill the engine it takes 10 or so minutes of choking it to get it to run then it lunges and acts as if it is flooded. Looking for recommendations on this and a good solid boat mechanic. Thanks

Bass Fishing Ad
Re: Mercury 2007 EFI 150 [Re: EtxBass] #13268700 09/03/19 02:07 PM
Joined: Feb 2006
Posts: 1,911
B
bronco71 Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Feb 2006
Posts: 1,911
First....there are no carbs on an EFI!! Did they replace filters, check hoses?


1999 Triton TX21/225 Mercury Optimax
Re: Mercury 2007 EFI 150 [Re: EtxBass] #13268723 09/03/19 02:22 PM
Joined: Jan 2015
Posts: 1,168
B
bassmanrudy Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Jan 2015
Posts: 1,168
no warranty for the work done by the marina?? especially for $4K... file a better business bureau complaint and at least make them answer it for all the world to see! has helped me in the past.


"I'd Rather Be Fishing" smile
Rudy
Re: Mercury 2007 EFI 150 [Re: EtxBass] #13268757 09/03/19 02:44 PM
Joined: Jan 2012
Posts: 678
H
harvey walker Offline
Pro Angler
Offline
Pro Angler
H
Joined: Jan 2012
Posts: 678
take it back to the shop and raise heck about it. IMO you got screwed

Re: Mercury 2007 EFI 150 [Re: bronco71] #13268758 09/03/19 02:44 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
They replaced the fuel system from the tank to the motor, and the throttle position indicator and still no luck.

Re: Mercury 2007 EFI 150 [Re: bassmanrudy] #13268759 09/03/19 02:45 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
They told me they were not mercury dealers and it took my 7 weeks to get my boat back and I don’t know they weren’t mercury dealers until I came back the second time

Re: Mercury 2007 EFI 150 [Re: harvey walker] #13268764 09/03/19 02:46 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
I talked to the owner and he said he apologized but it’s a screws up mess just looking for a new mechanic

Re: Mercury 2007 EFI 150 [Re: EtxBass] #13268901 09/03/19 04:32 PM
Joined: Nov 2008
Posts: 5,025
C
coachallentca Offline
TFF Celebrity
Offline
TFF Celebrity
C
Joined: Nov 2008
Posts: 5,025
Originally Posted by EtxBass
I talked to the owner and he said he apologized but it’s a screws up mess just looking for a new mechanic



is he going to fix it or give you some money back? Where are you located?


Cowboy Church bass club
Tournament Director
Re: Mercury 2007 EFI 150 [Re: coachallentca] #13269042 09/03/19 06:26 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
Originally Posted by coachallentca
Originally Posted by EtxBass
I talked to the owner and he said he apologized but it’s a screws up mess just looking for a new mechanic



is he going to fix it or give you some money back? Where are you located?


No sir, might as well have told me to go on with. I’m located by Cedar Creek

Re: Mercury 2007 EFI 150 [Re: EtxBass] #13269056 09/03/19 06:47 PM
Joined: Mar 2005
Posts: 4,448
L
Legend LE-195 Offline
TFF Team Angler
Offline
TFF Team Angler
L
Joined: Mar 2005
Posts: 4,448
Originally Posted by EtxBass
Originally Posted by coachallentca
Originally Posted by EtxBass
I talked to the owner and he said he apologized but it’s a screws up mess just looking for a new mechanic



is he going to fix it or give you some money back? Where are you located?


No sir, might as well have told me to go on with.


huh What?

Last edited by Legend LE-195; 09/03/19 06:48 PM.
Re: Mercury 2007 EFI 150 [Re: EtxBass] #13269059 09/03/19 06:50 PM
Joined: Nov 2014
Posts: 8,380
S
SteezMacQueen Offline
TFF Celebrity
Offline
TFF Celebrity
S
Joined: Nov 2014
Posts: 8,380
You are being screwed. Period.

First. It’s CARBS OR INJECTORS...not and. One of the other.

Second, I had to do the exact same thing to my Yamaha fourstroke 150. It included REMOVING the fuel tanks to clean them. All new hoses. ALL new filters and four NEW injectors. $800!! Not 4 grand. $800!!!!!! Took two days.


Eat. Sleep. Fish.
Re: Mercury 2007 EFI 150 [Re: SteezMacQueen] #13269097 09/03/19 07:13 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
I’ve had the injectors sent off to Florida for them to be cleaned and they recommend sending my computer to be checked but they were going to charge $750 for that but I sent it myself to Simon Motorsports and they said nothing is wrong with computer. I’m tired of dealing with it. Only boat I’ve had that has had this many problems, the motor has 29 hours on it. It’s ridiculous, I’ve put an ultrex and 2, 10 inch graphs and a 12 inch. Spent way too much money on this money hole it may find its self stuck on a stump on Lake Fork LOL, totally kidding

Re: Mercury 2007 EFI 150 [Re: EtxBass] #13269105 09/03/19 07:17 PM
Joined: Mar 2005
Posts: 4,448
L
Legend LE-195 Offline
TFF Team Angler
Offline
TFF Team Angler
L
Joined: Mar 2005
Posts: 4,448
Its a 2007 with only 29 hours? That may be your problem...

Re: Mercury 2007 EFI 150 [Re: EtxBass] #13269200 09/03/19 08:24 PM
Joined: May 2007
Posts: 102
dan805 Offline
Outdoorsman
Offline
Outdoorsman
Joined: May 2007
Posts: 102
i have a 2000 merc 200 ef1. it ran ok, But knew it wasn't right. every now and then would hesitate on launch. then run good. then later in the day hesitate, even run rich at times. did some reading and decided to send the ECU off to SIMON MOTORSPORTS in California, they do a complete rebuild for $650. Runs great ever since. I ended up finding a 2nd ECU as I wanted a spare in case. it's on it'w way back to me after being rebuilt.


2000 Champion 191 Merc 200EFI
There's only 1 way to Rock
Re: Mercury 2007 EFI 150 [Re: Legend LE-195] #13269273 09/03/19 09:10 PM
Joined: Sep 2019
Posts: 10
E
EtxBass Offline OP
Green Horn
OP Offline
Green Horn
E
Joined: Sep 2019
Posts: 10
Originally Posted by Legend LE-195
Its a 2007 with only 29 hours? That may be your problem...

How could that be my problem?

Page 1 of 2 1 2
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3