texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Skybone74, texasptb, fishguideswife, Sixstringsor12, Grald
110991 Registered Users
Top Posters(All Time)
TexDawg 91,395
hopalong 81,062
Pilothawk 78,469
John175ÔŅĹ 72,348
JDavis7873ģ 67,395
Derek 🐝 62,645
Tritonman 58,708
Bigbob_FTW 57,726
Mark Perry 56,199
facebook
Forum Statistics
Forums60
Topics756,689
Posts9,501,378
Members110,991
Most Online36,273
Jan 23rd, 2013
Print Thread
Bilge Pump Problem #13155530 05/15/19 11:31 PM
Joined: May 2009
Posts: 462
T
TheBombBait88 Offline OP
Angler
OP Offline
Angler
T
Joined: May 2009
Posts: 462
Iím having an issue where my bilge pump will come on automatically and it wonít turn off until I cut the Perko/power to the battery. The bilge switch can be off on the dash and it still comes on. It seems to happen after Iíve been on the water for a few hours, no water is coming out of the back either. Has anyone had an issue like this before?

Re: Bilge Pump Problem [Re: TheBombBait88] #13155812 05/16/19 06:24 AM
Joined: Feb 2014
Posts: 276
J
JB in Ft Worth Offline
Angler
Offline
Angler
J
Joined: Feb 2014
Posts: 276
Sounds like a wiring short. The ground wire going to the switch is probably shorting to ground.

Re: Bilge Pump Problem [Re: TheBombBait88] #13155884 05/16/19 11:57 AM
Joined: Apr 2010
Posts: 844
barbarian Online Content
Pro Angler
Online Content
Pro Angler
Joined: Apr 2010
Posts: 844
any chance that it has an auto float? might be some debris kicking it on if so.

Re: Bilge Pump Problem [Re: TheBombBait88] #13155941 05/16/19 12:55 PM
Joined: Nov 2002
Posts: 4,030
Gamblinman Online Content
TFF Team Angler
Online Content
TFF Team Angler
Joined: Nov 2002
Posts: 4,030
Replace the auto float or both the pump and auto float and be done with it.

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3