texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
SoonerTex0623, Bobby J., JPhillips1973, RTFishal, H1 ranger
119178 Registered Users
Top Posters(All Time)
hopalong 120,977
TexDawg 119,763
Bigbob_FTW 95,301
John175☮ 85,918
Pilothawk 83,274
Bob Davis 82,311
Mark Perry 72,473
Derek 🐝 68,321
JDavis7873 67,416
Forum Statistics
Forums59
Topics1,038,824
Posts13,953,508
Members144,178
Most Online39,925
Dec 30th, 2023
Print Thread
Ulterra won't deploy #14521027 10/31/22 12:53 PM
Joined: Mar 2003
Posts: 10,721
F
Fishin' Nut Offline OP
TFF Guru
OP Offline
TFF Guru
F
Joined: Mar 2003
Posts: 10,721
Over the last couple of months my Ulterra was becoming more sluggish when deploying or stowing. Once it deployed, it ran fine. Saturday it died. When I press the deploy button, it would move about an inch and freeze. Red status light would blink. Batteries are 2 12v 100ah lithium bought 14 months ago. My first guess is the trim motor has gone bad. Anything else I can check before taking it in for service?


Originally Posted by OTFF
He is truly a sick individual.
Re: Ulterra won't deploy [Re: Fishin' Nut] #14521149 10/31/22 03:03 PM
Joined: Jan 2009
Posts: 1,649
S
spankyttx Offline
Extreme Angler
Offline
Extreme Angler
S
Joined: Jan 2009
Posts: 1,649
have you seen this video, watch till the end

ulterra wont deploy


LI-SI-WI-NWI
Re: Ulterra won't deploy [Re: Fishin' Nut] #14521250 10/31/22 04:32 PM
Joined: Mar 2003
Posts: 10,721
F
Fishin' Nut Offline OP
TFF Guru
OP Offline
TFF Guru
F
Joined: Mar 2003
Posts: 10,721
I watched that one last night. It is on my check off list.


Originally Posted by OTFF
He is truly a sick individual.
Re: Ulterra won't deploy [Re: Fishin' Nut] #14540163 11/19/22 12:16 AM
Joined: Oct 2022
Posts: 4
R
ronsws6 Offline
Green Horn
Offline
Green Horn
R
Joined: Oct 2022
Posts: 4
Did that fix it?

Re: Ulterra won't deploy [Re: Fishin' Nut] #14540172 11/19/22 12:26 AM
Joined: May 2017
Posts: 136
T
TrailHand Offline
Outdoorsman
Offline
Outdoorsman
T
Joined: May 2017
Posts: 136
Here's a fix with pictures instead of video and it's for dummies lol. Used it myself in the past.

https://www.bbcboards.net/showthread.php?t=899313

Last edited by TrailHand; 11/19/22 12:26 AM.
Re: Ulterra won't deploy [Re: Fishin' Nut] #14541540 11/20/22 03:58 PM
Joined: Sep 2005
Posts: 27,563
Uncle Zeek Online Happy
aka "Dad"
Online Happy
aka "Dad"
Joined: Sep 2005
Posts: 27,563
Heh, mine just powers off when I try to deploy it. Both lights are steady on. I double tap the remote button, and the motor powers down.


"Decency is not news; it is buried in the obituaries --but it is a force stronger than crime" ~ Robert A. Heinlein
Artim Law Firm, PLLC
Estate planning & tax attorney
2250 Morriss Road, Suite 205, Flower Mound, Texas 75028
972-746-0758 mobile
zac@artimlegal.com
Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3