texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Half Past First Cast, JRB1129, russellslure, Kins.G, croppiepredater
117619 Registered Users
Top Posters(All Time)
TexDawg 110,982
hopalong 108,611
Bigbob_FTW 84,623
John175☮ 83,072
Pilothawk 82,435
Derek 🐝 67,858
JDavis7873 67,414
Mark Perry 67,140
Bob Davis 61,168
Forum Statistics
Forums60
Topics1,146,079
Posts15,634,210
Members142,619
Most Online36,273
Jan 23rd, 2013
Print Thread
Helix 9 Mega G2N SI stopped working #14329405 03/29/22 03:34 PM
Joined: Jan 2003
Posts: 2,876
R
RoadRunnerTR21 Online Content OP
Extreme Angler
OP Online Content
Extreme Angler
R
Joined: Jan 2003
Posts: 2,876
The screen shows no distinct images when SI screen is up. It looks like a flat bottom. Yesterday, when I headed out in the channel, I had docks on both sides of the boat and my range was 90 feet and it showed nothing. Out on the lake, I know I was around brush piles and it showed nothing other than what you would see for a flat bottom with no structure or fish. DI, Chirp and GPS all work like normal. Anybody have any troubleshooting suggestions I can try?

Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14329482 03/29/22 05:06 PM
Joined: Jan 2003
Posts: 2,876
R
RoadRunnerTR21 Online Content OP
Extreme Angler
OP Online Content
Extreme Angler
R
Joined: Jan 2003
Posts: 2,876
I just looked at my settings again and noticed that SI Chirp Display Frequency was NOT set to Mega Chirp. So I'm wondering if this could be the issue. I'm not going to be able to get the boat out until maybe the end of this week. I'm hoping that setting was the issue.

Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14334549 04/04/22 10:08 PM
Joined: Jan 2003
Posts: 2,876
R
RoadRunnerTR21 Online Content OP
Extreme Angler
OP Online Content
Extreme Angler
R
Joined: Jan 2003
Posts: 2,876
Still no luck. Last Friday the SI looked no different than before. It's either the head unit or the transducer. Anybody in the Cedar Creek Lake area have a Humminbird Helix Mega G2N interested in doing some trouble shooting?

Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14334610 04/04/22 11:09 PM
Joined: Mar 2012
Posts: 172
C
cliffshot Online Content
Outdoorsman
Online Content
Outdoorsman
C
Joined: Mar 2012
Posts: 172
I have two transducers . Both in good shape with transom mounts.

cliffhshot

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3