texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
SoonerTex0623, Bobby J., JPhillips1973, RTFishal, H1 ranger
119178 Registered Users
Top Posters(All Time)
hopalong 120,981
TexDawg 119,770
Bigbob_FTW 95,306
John175☮ 85,918
Pilothawk 83,274
Bob Davis 82,313
Mark Perry 72,476
Derek 🐝 68,321
JDavis7873 67,416
Forum Statistics
Forums59
Topics1,038,848
Posts13,953,908
Members144,178
Most Online39,925
Dec 30th, 2023
Print Thread
Helix 9 Mega G2N SI stopped working #14329405 03/29/22 03:34 PM
Joined: Jan 2003
Posts: 4,979
R
RoadRunnerTR21 Online Content OP
TFF Team Angler
OP Online Content
TFF Team Angler
R
Joined: Jan 2003
Posts: 4,979
The screen shows no distinct images when SI screen is up. It looks like a flat bottom. Yesterday, when I headed out in the channel, I had docks on both sides of the boat and my range was 90 feet and it showed nothing. Out on the lake, I know I was around brush piles and it showed nothing other than what you would see for a flat bottom with no structure or fish. DI, Chirp and GPS all work like normal. Anybody have any troubleshooting suggestions I can try?


[Linked Image] Light Blue 19 CPX
Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14329482 03/29/22 05:06 PM
Joined: Jan 2003
Posts: 4,979
R
RoadRunnerTR21 Online Content OP
TFF Team Angler
OP Online Content
TFF Team Angler
R
Joined: Jan 2003
Posts: 4,979
I just looked at my settings again and noticed that SI Chirp Display Frequency was NOT set to Mega Chirp. So I'm wondering if this could be the issue. I'm not going to be able to get the boat out until maybe the end of this week. I'm hoping that setting was the issue.


[Linked Image] Light Blue 19 CPX
Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14334549 04/04/22 10:08 PM
Joined: Jan 2003
Posts: 4,979
R
RoadRunnerTR21 Online Content OP
TFF Team Angler
OP Online Content
TFF Team Angler
R
Joined: Jan 2003
Posts: 4,979
Still no luck. Last Friday the SI looked no different than before. It's either the head unit or the transducer. Anybody in the Cedar Creek Lake area have a Humminbird Helix Mega G2N interested in doing some trouble shooting?


[Linked Image] Light Blue 19 CPX
Re: Helix 9 Mega G2N SI stopped working [Re: RoadRunnerTR21] #14334610 04/04/22 11:09 PM
Joined: Mar 2012
Posts: 193
C
cliffshot Offline
Outdoorsman
Offline
Outdoorsman
C
Joined: Mar 2012
Posts: 193
I have two transducers . Both in good shape with transom mounts.

cliffhshot

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3