texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
zooey026, allhandsondeck, thediscochef, rcpalaska, mjetton
115868 Registered Users
Top Posters(All Time)
TexDawg 104,066
hopalong 99,298
Pilothawk 81,173
John175☮ 79,866
Bigbob_FTW 75,729
JDavis7873 67,408
Derek 🐝 66,944
Mark Perry 63,763
Forum Statistics
Forums61
Topics1,155,670
Posts15,799,714
Members140,868
Most Online36,273
Jan 23rd, 2013
Print Thread
I pilot remote help #13944454 04/01/21 10:34 PM
Joined: Oct 2014
Posts: 452
ACES82 Offline OP
Angler
OP Offline
Angler
Joined: Oct 2014
Posts: 452
My iPilot remote has started acting up. It will turn on when you press a button, all the symbols light up and stay for about 5 seconds then turn off. Doesn’t engage the trolling motor. I’ve replaced the battery, flipped it over and tried to “reset” it. New battery. Anybody ever seen this and know of a cure or is it time for a new one? For a Minn Kota Riptide about 6 years old.

Last edited by ACES82; 04/01/21 10:35 PM.

Never Outsmart Common Sense.
Re: I pilot remote help [Re: ACES82] #13944865 04/02/21 11:28 AM
Joined: Nov 2014
Posts: 13,241
S
SteezMacQueen Online Happy
TFF Guru
Online Happy
TFF Guru
S
Joined: Nov 2014
Posts: 13,241
Have you tried repairing the Bluetooth?


Eat. Sleep. Fish.
Re: I pilot remote help [Re: ACES82] #13944875 04/02/21 11:42 AM
Joined: Sep 2003
Posts: 5,190
Bruce's Online Content
TFF Celebrity
Online Content
TFF Celebrity
Joined: Sep 2003
Posts: 5,190
Mine had water in it. You could mot tell by looking at it.. but it did. I had a friend take it apart and clean the board and reseal the glass. Been working fine since.


Bruce's Sprinkler Repair
817-798-7246
50 years experience
State Licensed Irrigation
LI0017483


Fishing Texas lakes one at a time






Re: I pilot remote help [Re: Bruce's] #13946345 04/03/21 10:48 PM
Joined: Feb 2014
Posts: 57
X
xse Online Content
Outdoorsman
Online Content
Outdoorsman
X
Joined: Feb 2014
Posts: 57
Down load the i pilot app to your cell phone. pair your cell phone, if it works then your remote is bad.


Mr. Ed
Previous Thread
Index
Next Thread

© 1998-2021 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3