Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Gkirk842, William Garcia, Trippmel, AznBassAngler, Jake Franklin
102690 Registered Users
Top Posters
TexDawg 82814
hopalong 74319
Pilothawk 73385
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59840
Tritonman 56773
Derek 56397
SkeeterRonnie 52442
LoneStarSon® 52197
facebook
Forum Stats
102690 Members
61 Forums
858390 Topics
11260688 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11120035 - 09/22/15 12:50 PM 2008 Evinrude ETEC 225 Tilt trim problems
ToadThrower Offline
Angler

Registered: 06/29/07
Posts: 316
Loc: Arlington, TX
Went to the lake this morning and when I went to get boat ready the up tilt trim switch on the motor, bow , or steering wheel would not work...thought it must be a bad relay...got home to try and locate the relays...and cant seem to find them...I pushed connections to make sure they were all connected...and tilt trim started working...put cover back on motor and tilt trim wouldnt work...removed cover moved the wires for trim switch to make sure they weren't contacting the cover or latches..checked trim switch and it worked...place cover back on motor and everything seems to work...Not wanting run into this again...can anyone give me guidance on how to maybe trouble shoot where there is a loose or bad connection...and where I would find the relay on this motor...I appreciate any assistance..or suggestions

Top
#11120928 - 09/22/15 08:04 PM Re: 2008 Evinrude ETEC 225 Tilt trim problems [Re: ToadThrower]
gary purdy Online   content
TFF Guru

Registered: 05/24/03
Posts: 10508
Loc: Littlefield Tx & Lake A. H. US...
My suggestion is you found the connection problem don`t worry about it. Put your model # here: http://www.boats.net/parts/search/BRP/EVINRUDE/parts.html
_________________________
“The world will not be destroyed by those who do evil, but by those who watch them without doing anything” GOD IS GOOD

Top
#11121101 - 09/22/15 08:57 PM Re: 2008 Evinrude ETEC 225 Tilt trim problems [Re: gary purdy]
ToadThrower Offline
Angler

Registered: 06/29/07
Posts: 316
Loc: Arlington, TX
Thanks..according to that link it is a relay assembly ...not the old type plug in relays I am used to seeing...I think I know where that part is now..so that is helpful...I am just worried that as I drive to the lake a bump in the road will result in the same problem...thanks for your help and the link.

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide