Texas Fishing Forum

Lowrance carbon issues please help

Posted By: Bass37

Lowrance carbon issues please help - 12/07/20 09:27 PM

Hey guys can anyone please help me with my issue. I have a 9 and 12 carbon unit and both units started giving me serious issues. Both units at different times. My 9 takes a good 2-4 minutes to power on and when it does it always acts like it is the first time to power on and I have to go through set up menu. My 12 now is having power on issues it will power on and get stuck on the standby screen and only way around is to unplug and try again. Works on the second time almost all the time. I have since then installed new blue top battery for just electronics and rewired all units to it with direct negative and positive.

Anyone with same issues?
Posted By: Rob Jasper Lowrance Pro-Staff

Re: Lowrance carbon issues please help - 12/07/20 09:38 PM

I would like to find out more about the issues. Are you starting your big engine while the units are trying to come up, what the software level is and what shape your batteries might be in. I am not saying it is a power issue, but will PM you if you want to call so we can go over a few things.
Posted By: PCEagle

Re: Lowrance carbon issues please help - 12/09/20 03:38 PM

Yes I have the same problem with my carbons. Started about six months ago continues to get worst. Updated them to the latest update last sat. Still have same problem as of yesterday.
Posted By: Rob Jasper Lowrance Pro-Staff

Re: Lowrance carbon issues please help - 12/09/20 07:18 PM

PC Eagle, I worked with Bass37 yesterday and got his unit to take the 20.0.1 update. I will send you a PM and you can call me and lets see if your problem is the same or slightly different.
© 2021 Texas Fishing Forum