Texas Fishing Forum

Hds Live Down-scan Issue

Posted By: LeonSulak

Hds Live Down-scan Issue - 10/26/20 01:25 AM

Thanks in advance for your help.

My downscan is not showing images well. What I mean is when I find brush piles, like today, and I go back directly over them, it doesnt really show up on the DI or in the water column on the sidescan. If anything there is a blob on the DI screen that doesnt reflect the actual size and on the sidescan I see a light faint trace of some stuff in the water column. Sidescan other than this works amazing. When the brush is off to the side of the water column, it is clear and great.

Unit has its one power supply from batter, unit has most recent update, transducer is level. My Gen 2s had more clear images for DI.

Thank you! I am about ready to switch the birds!
Posted By: Rob Jasper Lowrance Pro-Staff

Re: Hds Live Down-scan Issue - 10/27/20 07:18 PM

Try resetting the sonar defaults per below and run the Active Imaging on 800 kHz with sensitivity on A+3.
To reset sonar defaults: PAGES -- SETTINGS -- SONAR -- then in the middle of the screen, you will find RESET SONAR DEFAULTS
Only reason for sonar defaults is if you have gone in and changed a lot of settings trying to get a better picture.
Posted By: z289sec

Re: Hds Live Down-scan Issue - 10/28/20 12:56 AM

Originally Posted by LeonSulak
Thanks in advance for your help.

My downscan is not showing images well. What I mean is when I find brush piles, like today, and I go back directly over them, it doesnt really show up on the DI or in the water column on the sidescan. If anything there is a blob on the DI screen that doesnt reflect the actual size and on the sidescan I see a light faint trace of some stuff in the water column. Sidescan other than this works amazing. When the brush is off to the side of the water column, it is clear and great.

Unit has its one power supply from batter, unit has most recent update, transducer is level. My Gen 2s had more clear images for DI.

Thank you! I am about ready to switch the birds!


If you figure it out, please post what the fix was. My Helix Mega G3N unit is doing something very similar. I get what appears to be wisps of smoke all through the water column, and little to no detail in my down imaging. I can turn the sensitivity down, but to get rid of it, it has to almost eliminate everything on the screen. Definitely nothing like others pics of their down imaging.
Posted By: LeonSulak

Re: Hds Live Down-scan Issue - 10/28/20 03:21 PM

Thank you
© 2021 Texas Fishing Forum