Texas Fishing Forum

Hook2 5 Splitshot problem

Posted By: 603Country

Hook2 5 Splitshot problem - 05/31/20 06:17 PM

Something is wrong. I have power, but can only get the map screen. I can go to the other screens, but get nothing. There looks to be a place in the wiring to the Transducer that has been damaged (caught in the trolling motor framework, I expect). I’ll snip out the damaged spot and splice the wire, unless there’s something special about the wire. Is it easily snippable and spliceable? Let me know before I get wild and crazy and do something that requires a new transducer.

I’ve got the Garmin 106 unit up in front too, so the Hook2 5 isn’t absolutely needed, but if it’s going to be up there, it needs to work.
Posted By: BillS2006

Re: Hook2 5 Splitshot problem - 05/31/20 11:02 PM

What transducer are you using on the Hook2?
Posted By: 603Country

Re: Hook2 5 Splitshot problem - 06/01/20 01:16 PM

I don’t know which one it is, other than saying that it’s what came with the Splitshot unit - Hook2 5 HDI.
Posted By: Rob Jasper Lowrance Pro-Staff

Re: Hook2 5 Splitshot problem - 06/01/20 03:20 PM

I have seen transducer wiring getting crimped/mashed to the point it would not work due to the way the cable was installed on the trolling motor. If someone did the install for you (recent enough), they may feel responsible to replace it (if that is the problem). If the transducer needs to be replaced, you will HAVE to replace it with the same SS-HDI for HOOK2 that you have now.
Posted By: 603Country

Re: Hook2 5 Splitshot problem - 06/01/20 03:42 PM

Rob, is this a wire that can be spliced (before I cut it and try to splice it). As for the wire damage, I suppose it’s my fault. And I know about wrong transducers. When I first got the boat, it had the Splitshot on the front and the Tripleshot at the console, and neither worked. Finally I figured it out that the transducers were swapped out and connected to the wrong units. The seller fixed that.
Posted By: BillS2006

Re: Hook2 5 Splitshot problem - 06/01/20 06:33 PM

It is doubtful you can repair the transducer cable. Can you post a pic of the bad spot and the connector?
Posted By: 603Country

Re: Hook2 5 Splitshot problem - 06/01/20 09:57 PM

I don’t have a pic, but the wire is, for lack of a better term, squished. Flattened and partially opened up. Just the way you’d imagine that the trolling motor carriage would damage it. I can’t see a broken wire, but that doesn’t mean that one wire isn’t broken.
Posted By: BillS2006

Re: Hook2 5 Splitshot problem - 06/01/20 10:17 PM

If it's not cut thru, you can probably do a good tape job. What type of connector does it have? The push in? If so make sure it is seated as far as it can go.
Posted By: 603Country

Re: Hook2 5 Splitshot problem - 06/18/20 02:29 AM

The wire was damaged. I tried to splice the wire and failed. Oh, well...
© 2021 Texas Fishing Forum