Texas Fishing Forum

1996 175 EFI Magnum

Posted By: asmboat

1996 175 EFI Magnum - 05/31/20 03:00 PM

My motor has been great since 1999. It is 1996 175 EFI Magnum Mariner. Now.....it is really slow to plane out....and prob lost about 20mph of top end speed. If i had to guess i would say it is at 60% power. I absolutely feel like it isn't getting fuel. All coils were checked....fine. Compression was checked as well. Fresh water only boat.

I have ran 2 tanks of HEET treatment. I have replaced the gaskets, springs, and plastic washers on fuel pump. I have changed fuel line from transom to the motor including the bulb.

I have been advised it is injectors ($600 each). $3600 to replace them all.
I have wondered about the small pump inside the VST. I have continued to use the boat running 2 tanks of fuel....
Posted By: gary purdy

Re: 1996 175 EFI Magnum - 05/31/20 05:44 PM

That high pressure fuel pump screen needs replaced or cleaned. Check for full throttle activation at the linkage, clean the screen in the fuel pressure regulator, Injectors can be serviced for 45 to 60.00 dollars each. Next pull the cowling at the ramp while still tied to the trailer and pull vehicle. Start the outboard, run motor up to 2000 rpms in gear. then move the wires by hand that connect the harness to the ECM. If you hear a noticeable rpm increase the motors wiring harness needs to be replaced. Seen this several times. Good luck
Posted By: boatwhisperer

Re: 1996 175 EFI Magnum - 05/31/20 10:42 PM

have the injectors been checked or cleaned ?
Posted By: asmboat

Re: 1996 175 EFI Magnum - 06/01/20 02:04 AM

The injectors have not been checked or cleaned.

The high pressure fuel pump...is that in the VST?

I will try all that has been advised......and keep you posted.
Posted By: boatman025

Re: 1996 175 EFI Magnum - 06/01/20 01:57 PM

We can check your motor and get injectors clean for 25 each
Posted By: asmboat

Re: 1996 175 EFI Magnum - 06/13/20 03:51 PM

I pulled the VST off.
Checked the screen and the pump.
It all looked very clean.
I had to replace the o-ring for the VST.
I put it all back together.
Took a test ride.
Everything remained the same.

Still takes for ever to plain out. It will run about 35-40 MPH at full throttle.
Still runs rough like it isn't getting enough fuel at idol


Ready to get my boat motor back to normal..
Posted By: bronco71

Re: 1996 175 EFI Magnum - 06/13/20 04:22 PM

Originally Posted by boatman025
We can check your motor and get injectors clean for 25 each

Sure sounds like injectors.....
© 2021 Texas Fishing Forum