Texas Fishing Forum

Yamaha 175 HPDI Issues - Barely Gets on Plane?

Posted By: jpetro10

Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/02/19 07:34 PM

Not really sure how to describe what's going on but the outboard feels like its running at 50%. I should say it idles fine and I don't hear anything obvious but I'm not sure I would 'hear' any problems anyway but in terms of how it sounds when giving it gas or attempting to get on plane...all sounds normal.

The best way to describe what's going on is, I have a 2014 Skeeter TZX 195 that used to popup on plane quickly and get up to speed just fine. Randomly first trip out this weekend after launching the boat and letting it warm up I trim down and go to get on plane. The boat just basically plowed for 15+ seconds before finally getting on plane. Once it was on plane it just wouldn't get up to speed at all. I knew something was wrong when I tried to get on plane and it took forever.

It honestly feels like what I would imagine a boat with 5000 LBS too much on board would feel like, lol.

I'm taking into a mechanic but curiosity is getting the best of me. Any guesses?

Ooh, the motor has about 30 hours on it and has been problem free.
Posted By: Dug71

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/03/19 01:48 PM

Sounds like fuel lines coming apart inside, but being a 2014 shouldn't be having that problem. I would check the easy stuff first like fuel filters, bad gas? Something fuel related since it cannot supply enough at WOT.
Posted By: boatman025

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/03/19 01:58 PM

Where you located we can check it out for you
Posted By: jpetro10

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/03/19 02:27 PM

Originally Posted by Dug71
Sounds like fuel lines coming apart inside, but being a 2014 shouldn't be having that problem. I would check the easy stuff first like fuel filters, bad gas? Something fuel related since it cannot supply enough at WOT.


Thinking about 'easy stuff'...has anyone ever had the hot foot start to slip or I guess adjust on its own? That's honestly what I was thinking about checking because everything seems so normal.

Originally Posted by boatman025
Where you located we can check it out for you


I appreciate it! I'm in Austin and I have something scheduled. We're actually looking to move around your area though. If we do, I'll keep you guys in mind.
Posted By: jpetro10

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/04/19 06:01 PM

Welp...I learned a few things today.

1 - Throttle cable can slip out of where it's held
2 - Where the throttle cable is, lol!

We're back in business!
Posted By: Topwater2

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/04/19 07:27 PM

Glad it was an easy, no headache, no high dollar fix!
Posted By: jpetro10

Re: Yamaha 175 HPDI Issues - Barely Gets on Plane? - 06/04/19 11:46 PM

Originally Posted by Topwater2
Glad it was an easy, no headache, no high dollar fix!


It'll definitely be the cheapest I've walked out of the dealership, $0!
© 2022 Texas Fishing Forum