Texas Fishing Forum

Terrova Problem

Posted By: retiredfire

Terrova Problem - 11/29/19 03:48 AM

Was out fishing last weekend and whenever I put my Terrova on anchor it would hold for about 10 seconds then shut off and say it could not find the motor. I have never had a problem before, any help appreciated.
Posted By: JIM SR.

Re: Terrova Problem - 11/29/19 04:09 PM

remote battery weak...
Posted By: retiredfire

Re: Terrova Problem - 11/29/19 07:32 PM

Remove what battery? The batteries are about two years old and stay plugged to on board charger 24-7 when its not being used. Also the remote stays plugged in.
Posted By: shut-up-and-fish

Re: Terrova Problem - 11/29/19 11:43 PM


Sounds like you have the i-Pilot Link system. On the remote go to Options - scroll down to Arrival Mode and make sure it is on spotlock and not on-off.
Posted By: retiredfire

Re: Terrova Problem - 11/30/19 12:15 AM

Thanks I'll try that, do you sell the replacement batteries I bought the unit from ya'll?
Posted By: shut-up-and-fish

Re: Terrova Problem - 11/30/19 12:37 AM


The i-Pilot Link does not have a replacement battery. It is powered by a rechargeable Lithium-Ion Battery. I said above it sounds like you have the i-Pilot Link remote as you stated that you keep the remote plugged in.
Posted By: lurenthewind

Re: Terrova Problem - 12/01/19 06:12 AM

How old is the Terrova. Some folks with the Gen 1 Units have discussed problems with the I-Pilot. I think there is an upgrade kit available that fixes the problem.

Wayne
Posted By: snowyriver6

Re: Terrova Problem - 12/01/19 08:02 PM

upgrade kit is a new head..........500 dollars
Posted By: lurenthewind

Re: Terrova Problem - 12/03/19 04:53 AM

That's a chunk, but it is still less than a new motor IF it fixes the problem.

Wayne
© 2020 Texas Fishing Forum