texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
dndsam, sttebr, davebard, xaustenx, flaggert1
118688 Registered Users
Top Posters(All Time)
TexDawg 116,721
hopalong 116,072
Bigbob_FTW 91,018
John175ā˜® 85,105
Pilothawk 83,047
Bob Davis 74,839
Mark Perry 69,809
JDavis7873® 67,416
Forum Statistics
Forums59
Topics1,028,096
Posts13,753,201
Members143,688
Most Online36,273
Jan 23rd, 2013
Print Thread
Helix 15 problem #14758378 06/23/23 08:02 PM
Joined: Dec 2005
Posts: 458
W
wild bill Offline OP
Angler
OP Offline
Angler
W
Joined: Dec 2005
Posts: 458
Iā€™m pretty good with my electronics but this one has me stumped . The down image does not show up. Can one side of transducer quit working? While side and sonar work ?
Never run into this problem. Your helpful input will be welcomed.
Thank you
Wild bill


Fishing and Dogs, how much fun can one old guy have !!!
Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Helix 15 problem [Re: wild bill] #14758388 06/23/23 08:10 PM
Joined: Nov 2010
Posts: 5,029
W
Wayne P. Online Content
TFF Celebrity
Online Content
TFF Celebrity
W
Joined: Nov 2010
Posts: 5,029
A Helix 15 is a fourth generation model (G4N). The SI transducer has a left SI piezo, a right SI piezo, a DI piezo and a HW CHIRP piezo. You can have a failed piezo, damaged cable, faulty connection, or a failing unit. If you have another MEGA SI unit you can cross-test with or know someone that you can test your unit with and test your unit on their MEGA SI transducer, then you can figure out what the issue is. Otherwise you would need to purchase a MEGA SI + transducer to find out.


Helix 12 CHIRP MEGA SI+ GPS G3N and G4N, 1198c SI, SOLIX 10 SI G3,
Helix 10 MEGA DI+ GPS G3N, SOLIX 12 SI and G3, MEGA 360, MEGA LIVE TL, RC-1
Re: Helix 15 problem [Re: wild bill] #14758407 06/23/23 08:41 PM
Joined: Mar 2002
Posts: 1,221
P
prosise Online Content
Extreme Angler
Online Content
Extreme Angler
P
Joined: Mar 2002
Posts: 1,221
Yep, my buddy had one side image signal go out on his helix. We swapped his unit to my boat and it worked. It was a transducer problem.

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3