texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
cshamblin, GreyGhost, Disinclined, Bluerock, tsegraves
117796 Registered Users
Top Posters(All Time)
TexDawg 112,027
hopalong 109,930
Bigbob_FTW 85,642
John175☮ 83,662
Pilothawk 82,585
Derek 🐝 67,922
Mark Perry 67,740
JDavis7873 67,414
Bob Davis 63,689
Forum Statistics
Forums60
Topics1,149,164
Posts15,689,195
Members142,796
Most Online36,273
Jan 23rd, 2013
Print Thread
Motorguide Xi3 won't deploy #14574480 12/24/22 06:30 PM
Joined: Mar 2010
Posts: 242
W
wrestlefish Offline OP
Outdoorsman
OP Offline
Outdoorsman
W
Joined: Mar 2010
Posts: 242
I have a Xi3 saltwater i bought in may of 2021. Used it twice. Both times it was tough to deploy and I was struggling with the pinpoint. PUt it off to user error. Then my main motor went down in June and it sat inside storage until now. Just put a brand new Yamaha 115 SHO on my Bluewave. Love it. So I take my "new" boat out and again, trolling motor difficult to deploy. But I got it. And it took forever to find gps signal but the light finally came on. Found a brush pile, hit anchor mode and we preceded to move erratically around the spot. It is like it loses signal, drifts off, and then lurches back to the spot when the signal is regained. This has been normal behavior for this unit. But now I can't even get it out of the cradle. It is on a quick release bracket. I hear this is a great unit. Maybe I got a lemon. how do I get this thing out of the cradle. I took the side pieces off so I can see the pins which do move. It is like it is siezed up. The cradle will not move forward when I push.

Last edited by wrestlefish; 12/24/22 06:34 PM.
Re: Motorguide Xi3 won't deploy [Re: wrestlefish] #14575482 12/25/22 05:13 PM
Joined: May 2019
Posts: 270
J
JAlfred Offline
Angler
Offline
Angler
J
Joined: May 2019
Posts: 270
Spraying some garage door lubicant into the deploying mechanism fixed my freshwater version. Regarding GPS, you may just need to calibrate it. My spotlock function is very unreliable. Often when I initiate it, the motor spins 360 hard against the wiring. Even when it's working, it doesn't hold the boat very well. Motorguide support is not very helpful, so I gave up on that route. For me, the trolling motor is just good enough for now, so that I am not replacing it.

Re: Motorguide Xi3 won't deploy [Re: wrestlefish] #14575739 12/26/22 12:59 AM
Joined: Mar 2010
Posts: 242
W
wrestlefish Offline OP
Outdoorsman
OP Offline
Outdoorsman
W
Joined: Mar 2010
Posts: 242
I greased it up but it is like it is welded in place. It won't budge. Crazy. It seems like the cradle should move forward. It just stays there. When I press the lever the pins move, but that is all that moves. Everything else is frozen. Frustrating on a motor that has been used less than 6 times.

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3