texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jeffish_27, Clavelle2003, TexasGambit, Jstewart, Aggie_angler22
117428 Registered Users
Top Posters(All Time)
TexDawg 109,962
hopalong 107,074
Bigbob_FTW 83,105
John175☮ 82,285
Pilothawk 82,235
Derek 🐝 67,772
JDavis7873 67,408
Mark Perry 66,524
Forum Statistics
Forums59
Topics1,143,053
Posts15,583,834
Members142,428
Most Online36,273
Jan 23rd, 2013
Print Thread
ETEC Mechanic ? #14467858 09/04/22 02:26 PM
Joined: Jan 2011
Posts: 1,690
W
WTBOATMAN Offline OP
Extreme Angler
OP Offline
Extreme Angler
W
Joined: Jan 2011
Posts: 1,690
I have a 150 ETEC , Motor starts fine , Runs good up to about 1800 rpms, after that until up to about 2500 rpms it feel like it is missing but doesn't loose spark, after 2700 RPM's motor will run good all the way through the range to top end
While running diagnostics I can richen 1,2,3 injectors and seem to run though these RPM's fine
Hard for me to imagine that it is a injector issue.

MAYBE ECU ?

Last edited by WTBOATMAN; 09/04/22 02:26 PM.
Re: ETEC Mechanic ? [Re: WTBOATMAN] #14467867 09/04/22 02:35 PM
Joined: Apr 2017
Posts: 8,539
tmd11111 Online Content
TFF Celebrity
Online Content
TFF Celebrity
Joined: Apr 2017
Posts: 8,539
https://www.etecownersgroup.com/

Tons of help and knowledge in this group. Make sure if you post on there to include model number and serial number

Re: ETEC Mechanic ? [Re: tmd11111] #14467886 09/04/22 03:01 PM
Joined: Jan 2011
Posts: 1,690
W
WTBOATMAN Offline OP
Extreme Angler
OP Offline
Extreme Angler
W
Joined: Jan 2011
Posts: 1,690
Originally Posted by tmd11111
https://www.etecownersgroup.com/

Tons of help and knowledge in this group. Make sure if you post on there to include model number and serial number



THANX FOR THE LEAD

Re: ETEC Mechanic ? [Re: WTBOATMAN] #14476175 09/13/22 01:11 PM
Joined: Jan 2011
Posts: 1,690
W
WTBOATMAN Offline OP
Extreme Angler
OP Offline
Extreme Angler
W
Joined: Jan 2011
Posts: 1,690
TTT

Re: ETEC Mechanic ? [Re: WTBOATMAN] #14476620 09/13/22 07:30 PM
Joined: Jan 2009
Posts: 495
D
drifter106 Online Content
Angler
Online Content
Angler
D
Joined: Jan 2009
Posts: 495
Originally Posted by WTBOATMAN
I have a 150 ETEC , Motor starts fine , Runs good up to about 1800 rpms, after that until up to about 2500 rpms it feel like it is missing but doesn't loose spark, after 2700 RPM's motor will run good all the way through the range to top end
While running diagnostics I can richen 1,2,3 injectors and seem to run though these RPM's fine
Hard for me to imagine that it is a injector issue.

MAYBE ECU ?


Hope you get the motor running...kind of a bad deal with the etec thing. I have a 90 hp etec on our bass boat. Sure would hate to have something go wrong with it. Not for sure how the "parts" situation would be since they went out of business.


Sacred heart of Mary, pray for us now and at the hour of our death. Amen
For those who believe, no explanation is necessary....for those who don't, no explanation is possible
For the sake of his sorrowful Passion, have Mercy on us and the whole world
Re: ETEC Mechanic ? [Re: WTBOATMAN] #14484857 09/22/22 01:40 PM
Joined: Jan 2011
Posts: 1,690
W
WTBOATMAN Offline OP
Extreme Angler
OP Offline
Extreme Angler
W
Joined: Jan 2011
Posts: 1,690
TTT

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3