texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jeffish_27, Clavelle2003, TexasGambit, Jstewart, Aggie_angler22
117428 Registered Users
Top Posters(All Time)
TexDawg 109,962
hopalong 107,074
Bigbob_FTW 83,105
John175☮ 82,285
Pilothawk 82,235
Derek 🐝 67,772
JDavis7873 67,408
Mark Perry 66,524
Forum Statistics
Forums59
Topics1,143,056
Posts15,583,869
Members142,428
Most Online36,273
Jan 23rd, 2013
Print Thread
Aging livescope issues #14456706 08/23/22 12:24 AM
Joined: Jan 2007
Posts: 62
R
Rnelson Offline OP
Outdoorsman
OP Offline
Outdoorsman
R
Joined: Jan 2007
Posts: 62
Ok so I purchased the very first run of livescope and a 93sv. So its been running none stop sense. Took some time to learn but after the first season no problems. I could go to different bodies of water adjust the unit and bang. Fast forward to this year. I have a really bad ghost tree halo and it will not adjust. Done everything possible new updates blah blah. Even hand cleaned the pins on the black box. Basically not clear. I have screen shots for year one and its night and day. I still fishible but frustrating.

So my question is to the first buyers. Is your unit as good as when your purchased it.


Mine isn't

Maybe sense i dony have a uhd and no updates to the head unit "maybe"

Last edited by Rnelson; 08/23/22 12:36 AM.
Re: Aging livescope issues [Re: Rnelson] #14458604 08/24/22 11:05 PM
Joined: Oct 2002
Posts: 6,069
R
ring fry Offline
TFF Celebrity
Offline
TFF Celebrity
R
Joined: Oct 2002
Posts: 6,069
I've got one of the very first ones made. I've kept my unit updated and see no difference between now and then.

Retired grass grower


2008, 2022 NCAA Men's Basketball Champions
GO JAYHAWKS

Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3