texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
zooey026, allhandsondeck, thediscochef, rcpalaska, mjetton
115868 Registered Users
Top Posters(All Time)
TexDawg 104,063
hopalong 99,298
Pilothawk 81,173
John175☮ 79,865
Bigbob_FTW 75,726
JDavis7873 67,408
Derek 🐝 66,943
Mark Perry 63,762
Forum Statistics
Forums61
Topics1,155,669
Posts15,799,672
Members140,868
Most Online36,273
Jan 23rd, 2013
Print Thread
Ulterra Riptide 36 v motor error #14057220 07/09/21 08:15 PM
Joined: Jan 2002
Posts: 1,407
Micheal Online Content OP
Extreme Angler
OP Online Content
Extreme Angler
Joined: Jan 2002
Posts: 1,407
Ulterra Riptide 36V Motor error
I have a new Ulterra that has never been in the water. Tried it out on the trailer to see if everything cleared. Everything seemed to work as it should.
Took it out to fish and it would deploy and then I get a motor error. It will stow. I can deploy and stow all I want but that is all.
I have tested the batteries with a voltmeter and a load tested. They are within spec. I hard wired the motor to the battery cables with Corrosion X and shrink tubing. I still get the same results. I put the batteries on the charger and tried again after they charged overnight. Same results.

A what have I missed? Any help would be appreciated.


Micheal's Marine. Mobile Boat-Motor Repair Ser.
Dakota Lithium Battery Dealer
Lake Fork Trolling Motor sales and ser. Lowrance Dealer
Re: Ulterra Riptide 36 v motor error [Re: Micheal] #14057832 07/10/21 04:17 PM
Joined: Mar 2004
Posts: 330
I
iFloat Offline
Angler
Offline
Angler
I
Joined: Mar 2004
Posts: 330
Minn kota tech support is your best option.

There is a reset you can do, something to do with holding power button down or clicking it 3 times I can't remember. If that doesn't fix it, the tech support people walk you through a process. IF that doesn't fix it, you'd have to take to shop.

I went through this a month ago... the repair shop has had my ulterra for nearly a month... very frustrating. Mine was 2 years old.

Previous Thread
Index
Next Thread

© 1998-2021 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3