texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Joshep P, Doc_0424, Vital, TX Salty Bay, AggieBowhunter13
115218 Registered Users
Top Posters(All Time)
TexDawg 101,780
hopalong 96,127
Pilothawk 80,816
John175☮ 78,924
Bigbob_FTW 73,136
JDavis7873 67,402
Derek 🐝 66,456
Mark Perry 62,615
Forum Statistics
Forums61
Topics1,146,611
Posts15,673,068
Members140,218
Most Online36,273
Jan 23rd, 2013
Print Thread
02 sensor on 2004 225 ox66 #13836039 01/07/21 05:22 PM
Joined: Mar 2012
Posts: 154
H
hawkeye442 Online Content OP
Outdoorsman
OP Online Content
Outdoorsman
H
Joined: Mar 2012
Posts: 154
Hello Folks,

 I recently ordered a new o2 sensor for my YAMAHA OX66 because I found burned wires on the old one. In the process of replacing and cleaning, I removed the o2 sensor holder, I ordered a new gasket set and am a little confused as to how it all goes back together as I didn't find some of these gaskets when I took it apart. It also looked like the gasket was blown because there was oil inside the plastic cover that houses the o2 sensor, and I know it should be sealed up for the 02 sensor to properly work. I've attached a diagram that is for my engine. My question is , where does the rubber o-ring go( 44 is the 0-ring, 45 is a gasket)? I would think rubber would melt at such high temps?

any help would be appreciated.

TIA

Attached Files Inkedo2 sensor - Copy_LI.jpg
Re: 02 sensor on 2004 225 ox66 [Re: hawkeye442] #13836300 01/07/21 07:14 PM
Joined: Jul 2010
Posts: 1,049
B
boatman025 Online Content
Extreme Angler
Online Content
Extreme Angler
B
Joined: Jul 2010
Posts: 1,049
PM me


Hughes Marine
3855 Osage Lane
Wylie ,Texas
Previous Thread
Index
Next Thread

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3