texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
BigVelvet, IntoTheWildFlyFishing, Lsquare65, cettel, Muckbux
114683 Registered Users
Top Posters(All Time)
TexDawg 100,628
hopalong 94,375
Pilothawk 80,701
John175☮ 78,681
Bigbob_FTW 71,283
JDavis7873 67,401
Derek 🐝 66,120
Mark Perry 62,232
Forum Statistics
Forums61
Topics1,141,092
Posts15,589,892
Members139,683
Most Online36,273
Jan 23rd, 2013
Print Thread
3.0 merc efi oil primeing #13701778 09/15/20 10:38 PM
Joined: Jul 2008
Posts: 6,642
B
bradnitro175 Online Content OP
TFF Celebrity
OP Online Content
TFF Celebrity
B
Joined: Jul 2008
Posts: 6,642
Well ran my onboard oil tank dry sunday.I filled her up and cracked the cap on the motor tank while idling and it wasn't going passed 3/4 full.does it take awhile to fill up? Kept getting the 4 beep oil alarm on smartcraft gauge.


Originally Posted by Frank the Tank
I hope it’s as big as you say it is Hop. Don’t wanna be disappointed

Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13701959 09/16/20 02:07 AM
Joined: Jan 2004
Posts: 2,306
R
rb7764 Online Content
Extreme Angler
Online Content
Extreme Angler
R
Joined: Jan 2004
Posts: 2,306
Make sure the screen on the bottom of the pickup in the main tank is clean. Then make sure the seal is snug. Could also be the sensor in the use tank. Have you checked it?

Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13701970 09/16/20 02:16 AM
Joined: Jul 2008
Posts: 6,642
B
bradnitro175 Online Content OP
TFF Celebrity
OP Online Content
TFF Celebrity
B
Joined: Jul 2008
Posts: 6,642
Not yet I here those tanks sensors are expensive tho.


Originally Posted by Frank the Tank
I hope it’s as big as you say it is Hop. Don’t wanna be disappointed

Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13702244 09/16/20 01:52 PM
Joined: Jul 2010
Posts: 1,014
B
boatman025 Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Jul 2010
Posts: 1,014
You have to replace oil tank and there not that bad, make sure screen clean and no kinks n hoses , make sur no cracks


Hughes Marine
3855 Osage Lane
Wylie ,Texas
Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13702265 09/16/20 02:11 PM
Joined: Feb 2006
Posts: 2,619
B
bronco71 Online Content
Extreme Angler
Online Content
Extreme Angler
B
Joined: Feb 2006
Posts: 2,619
Does your remote tank have a deck fill cap? My hose got an air leak from the deck to the remote tank and I could not fully fill the onboard tank.


1999 Triton TX21/225 Mercury Optimax
Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13702418 09/16/20 05:03 PM
Joined: Jul 2010
Posts: 1,014
B
boatman025 Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Jul 2010
Posts: 1,014
We can get it check out for you


Hughes Marine
3855 Osage Lane
Wylie ,Texas
Re: 3.0 merc efi oil primeing [Re: bradnitro175] #13704546 09/19/20 12:01 AM
Joined: Jul 2008
Posts: 6,642
B
bradnitro175 Online Content OP
TFF Celebrity
OP Online Content
TFF Celebrity
B
Joined: Jul 2008
Posts: 6,642
Just filled the outboard tank up with oil put key in run, still beeping.must be sensor or something


Originally Posted by Frank the Tank
I hope it’s as big as you say it is Hop. Don’t wanna be disappointed

Previous Thread
Index
Next Thread

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3