texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Zog, kiwifisherman, Mommamea, Teis, Simba
115183 Registered Users
Top Posters(All Time)
TexDawg 101,660
hopalong 95,976
Pilothawk 80,804
John175☮ 78,900
Bigbob_FTW 72,986
JDavis7873 67,402
Derek 🐝 66,420
Mark Perry 62,565
Forum Statistics
Forums61
Topics1,146,098
Posts15,665,056
Members140,183
Most Online36,273
Jan 23rd, 2013
Print Thread
Lowrance HDS Carbon problems! #13700156 09/14/20 12:34 PM
Joined: Feb 2010
Posts: 154
B
Ben B Offline OP
Outdoorsman
OP Offline
Outdoorsman
B
Joined: Feb 2010
Posts: 154
I posted this in the bass fishing section, but I'm hoping to have some luck here as well...

I have 2 HDS Carbon 9's and the one at the console is acting weird. Last weekend it cut out about midway through the day and every time I restart it would just sit on the home screen. Then today it started doing the same thing, but then a different home screen came up - however the lettering was fuzzy...kind of like what you would see on a television. Also - and I'm not sure if this would be related to the issue - but the screen was VERY hot to the touch. Is it possible the unit is somehow overheating? And what would cause that?

Re: Lowrance HDS Carbon problems! [Re: Ben B] #13700379 09/14/20 03:42 PM
Joined: Oct 2001
Posts: 14,041
M
Mo Offline
TFF Guru
Offline
TFF Guru
M
Joined: Oct 2001
Posts: 14,041
how is your voltage ? do they act up when starting the big motor ?

I know my units get hot , I am not sure if it is internal or just from sitting in in sun.

MO



MY BACKYARD , 20,000 ACRES , NO MOWING smile
Previous Thread
Index
Next Thread

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3