texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Bwbell, USMCJOKER, Bobby Hatfield, subaruliving, Big Bass Rob
115032 Registered Users
Top Posters(All Time)
TexDawg 101,371
hopalong 95,542
Pilothawk 80,776
John175☮ 78,846
Bigbob_FTW 72,543
JDavis7873 67,402
Derek 🐝 66,290
Mark Perry 62,472
Forum Statistics
Forums61
Topics1,144,598
Posts15,641,753
Members140,032
Most Online36,273
Jan 23rd, 2013
Print Thread
Lowrance Elite 9 Ti2 shuts down after boot up #13692943 09/06/20 11:28 PM
Joined: Jun 2010
Posts: 31
4
488tx Offline OP
Outdoorsman
OP Offline
Outdoorsman
4
Joined: Jun 2010
Posts: 31
I just installed an Elite 9 Ti2 on a new boat and after about 90 seconds the unit shuts down, there is no back lighting and no beeps when i press the buttons. I have used 3 separate power sources of 13.5 -14 volts. Is anyone else having problems with the Ti2 shutting off?


Re: Lowrance Elite 9 Ti2 shuts down after boot up [Re: 488tx] #13693026 09/07/20 01:11 AM
Joined: Apr 2017
Posts: 5,190
tmd11111 Online Content
TFF Celebrity
Online Content
TFF Celebrity
Joined: Apr 2017
Posts: 5,190
Wait until dark or get a big towel to put over the graph and look under it when you boot it up. You may have accidently turned the screen brightness down all the way. If so it will look like the screen went blank. I've done this a time or two with my Ti's.

Re: Lowrance Elite 9 Ti2 shuts down after boot up [Re: tmd11111] #13693039 09/07/20 01:20 AM
Joined: Jun 2010
Posts: 31
4
488tx Offline OP
Outdoorsman
OP Offline
Outdoorsman
4
Joined: Jun 2010
Posts: 31
That is a good point but my understanding is that if the screen is dim the buttons will make a beeping noise when they are pressed. Also, it will turn off while I am trying to perform system setup.

Thanks for the idea.


Previous Thread
Index
Next Thread

Moderated by  Duck_Hunter 

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3