texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
deesenland, Fisher Girl, CC2SA333, Chihuahuin, RYS Ministry
113764 Registered Users
Top Posters(All Time)
TexDawg 97,078
hopalong 89,715
Pilothawk 80,177
John175☮ 77,777
JDavis7873 67,400
Bigbob_FTW 67,138
Derek 🐝 64,939
Mark Perry 60,723
Tritonman 58,986
facebook
Forum Statistics
Forums62
Topics780,504
Posts9,903,778
Members113,764
Most Online36,273
Jan 23rd, 2013
Print Thread
Helix 12 G2 no longer boots up #13668952 08/15/20 06:34 PM
Joined: Apr 2006
Posts: 18,482
O
outfishdya Online Happy OP
TFF Guru
OP Online Happy
TFF Guru
O
Joined: Apr 2006
Posts: 18,482
Well it finally failed on me. I have a 2019 zx225 with the standard 12 on the console and 9 on the bow. Both Gen 2 Mega SI yada yada .... Towards the end of summer last year, I was having an issue where 12 would shut off when cranking the engine. If this happened, it was pretty much an act of God to get the front unit to network back online with the 12 which displayed the SI, and even if it did reconnect, it was not giving me an SI image worth looking at. It certainly did not match the image coming from the 12. This year I re wired the ACC wiring for the net hub and for the 12 to correct the voltage drop issue, if that was really causing the unit to shutdown, but now the unit shuts off from what I have to assume is overheating. It never happens at night or in the morning, but the Texas sun seems to make it shutoff. When this happens, it will not reboot, or it only has black lines on the screen. Well, yesterday it shutdown and it will no longer boot up at all. I have it in the house with a battery out of the sun in a cool area, I am wiring it straight to battery. It appears to be a brick. It has black lines and makes noised like it changing views and such in the back ground.
Any Ideas?

Re: Helix 12 G2 no longer boots up [Re: outfishdya] #13669062 08/15/20 08:03 PM
Joined: Dec 2012
Posts: 6,282
44 Diesel Online Content
TFF Celebrity
Online Content
TFF Celebrity
Joined: Dec 2012
Posts: 6,282
If you have an sd or map cards in it try removing them before you power it up. If it that works then back up all your nav data to an sd. Then you will need to format nav directories, this will delete all nav data. Corrupt waypoints can cause the units to crash. If that is not the issue then probably needs to go back to Humminbird

Re: Helix 12 G2 no longer boots up [Re: 44 Diesel] #13669177 08/15/20 10:00 PM
Joined: Apr 2006
Posts: 18,482
O
outfishdya Online Happy OP
TFF Guru
OP Online Happy
TFF Guru
O
Joined: Apr 2006
Posts: 18,482
Originally Posted by 44 Diesel
If you have an sd or map cards in it try removing them before you power it up. If it that works then back up all your nav data to an sd. Then you will need to format nav directories, this will delete all nav data. Corrupt waypoints can cause the units to crash. If that is not the issue then probably needs to go back to Humminbird

Thank you for the reply
I had already tried that in my troubleshooting.
Tried HB tech support today, but was on hold too long. They may be mon thru fri....
Their site says to send all transducers, cables and hubs in with the unit. Surely they don't need that for a unit that wo t boot up. Any one else send everything in to them?

Re: Helix 12 G2 no longer boots up [Re: outfishdya] #13669199 08/15/20 10:24 PM
Joined: Dec 2012
Posts: 6,282
44 Diesel Online Content
TFF Celebrity
Online Content
TFF Celebrity
Joined: Dec 2012
Posts: 6,282
Just a head unit is all you will need to send in. C/S is open on Saturday and Sundays from 8-430. Mondays are not good times to call

Previous Thread
Index
Next Thread

Moderated by  Duck_Hunter 


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3