texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Bassjiggin1955, Jaws81, AtumAnt, johnwflynn73, Fishinggal2468
117419 Registered Users
Top Posters(All Time)
TexDawg 109,942
hopalong 107,060
Bigbob_FTW 83,065
John175☮ 82,276
Pilothawk 82,219
Derek 🐝 67,771
JDavis7873 67,408
Mark Perry 66,504
Forum Statistics
Forums59
Topics1,142,953
Posts15,582,427
Members142,419
Most Online36,273
Jan 23rd, 2013
Print Thread
Power tilt & trim loses pressure under load #13582488 06/04/20 02:28 PM
Joined: Jul 2013
Posts: 467
diggerwolf Offline OP
Angler
OP Offline
Angler
Joined: Jul 2013
Posts: 467
Last weekend on the lake my power tilt & trim stopped working under load. It would go up & down just fine while on the ramp or idling in the water, but would drop back down as soon as I accelerated.

Got it home and checked everything as best I could. I do not see any leaks, hydraulic fluid seems to be topped off and no signs of water, operates smoothly and normally with no grinding or weird noises.

The problem seems to be only on the water. Will trim up but will not stay there.

Any ideas?

2003 Skeeter with 2003 Yamaha VMax 3.1L



"Life should not be a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in broadside in a cloud of smoke, thoroughly used up, totally worn out, and loudly proclaiming "Wow! What a Ride!" ― Hunter S. Thompson
Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13583528 06/05/20 03:41 AM
Joined: Apr 2004
Posts: 12,260
S
Stump jumper Online Content
TFF Guru
Online Content
TFF Guru
S
Joined: Apr 2004
Posts: 12,260
Might be time for a new pump and motor. I had a Mercury that would not stay tilted from new. Seals on pump replaced under warranty and it would still bleed down on tilt only. Years later after one motor rebuild I bought a new pump and motor and never had another problem.


2200 Bay Champ/200 Mercury Optimax
2017 Tundra TSS 4x4 Crewmax 5.7L
Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13583643 06/05/20 11:25 AM
Joined: Sep 2010
Posts: 1,599
B
boatwhisperer Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Sep 2010
Posts: 1,599
first and easiest would be the o rings on the manueltrlrasr valve will need a service manual


boatwhisperer
Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13583744 06/05/20 01:21 PM
Joined: Apr 2008
Posts: 1,007
B
Big Hopper Offline
Extreme Angler
Offline
Extreme Angler
B
Joined: Apr 2008
Posts: 1,007
DIGGERWOLF .... PM sent


I'm glad there are wine drinkers in this world ..... it saves more beer for the rest of us.
Hopper
Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13584540 06/05/20 11:13 PM
Joined: Jun 2004
Posts: 1,506
O
OPTI Offline
Extreme Angler
Offline
Extreme Angler
O
Joined: Jun 2004
Posts: 1,506
Valve body, manual releive valve or port trim ram.......OPTI

Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13604091 06/22/20 04:28 PM
Joined: Jul 2013
Posts: 467
diggerwolf Offline OP
Angler
OP Offline
Angler
Joined: Jul 2013
Posts: 467
UPDATE:

Found a mobile boat mechanic who diagnosed and rebuilt the trim motor.

Again, worked fine while on the trailer.

Took it on the water this Saturday and experienced the same problem as before. Will tilt up at a stop, but will not trim up while underway. Tried tilting up while at stop and then applying gas but the motor would drop right back down.

The mobile mechanic agreed to honor his work, but I think he's stumped.


"Life should not be a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in broadside in a cloud of smoke, thoroughly used up, totally worn out, and loudly proclaiming "Wow! What a Ride!" ― Hunter S. Thompson
Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13604888 06/23/20 06:58 AM
Joined: Feb 2015
Posts: 4,693
F
Flippin-Out Offline
TFF Team Angler
Offline
TFF Team Angler
F
Joined: Feb 2015
Posts: 4,693
You must have a valve/seal leaking somewhere - from the high pressure side of the hydraulic system to the low pressure side, not a leak that drips fluid. If there is a manual pressure relief valve, I would suspect some part of that is not sealing 100%. It holds well enough for the static weight of the motor, but when a heavy load is applied (engine thrust), the seal fails and the bypass leak begins. I'd replace all the seals elsewhere in the system. One has got to be letting pressure get by.

Re: Power tilt & trim loses pressure under load [Re: diggerwolf] #13605416 06/23/20 05:31 PM
Joined: Apr 2004
Posts: 12,260
S
Stump jumper Online Content
TFF Guru
Online Content
TFF Guru
S
Joined: Apr 2004
Posts: 12,260
Did he just rebuild the motor? What about the pump? Like I stated in previous post I had problems with mine from new until I replaced the complete assembly, pump and motor.


2200 Bay Champ/200 Mercury Optimax
2017 Tundra TSS 4x4 Crewmax 5.7L
Previous Thread
Index
Next Thread

© 1998-2022 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3