texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jjgray, tgray, Zhiggy, FF1437, ccr622
112855 Registered Users
Top Posters(All Time)
TexDawg 94,590
hopalong 86,574
Pilothawk 79,701
John175☮ 77,208
JDavis7873 67,398
Derek 🐝 64,232
Bigbob_FTW 64,156
Mark Perry 59,771
Tritonman 58,900
facebook
Forum Statistics
Forums62
Topics779,301
Posts9,828,951
Members112,855
Most Online36,273
Jan 23rd, 2013
Print Thread
Yahama 1997 115 problems #13566239 05/21/20 02:48 PM
Joined: Aug 2010
Posts: 68
R
RogerC Offline OP
Outdoorsman
OP Offline
Outdoorsman
R
Joined: Aug 2010
Posts: 68
I have a Yahama 1997 115 hp that is stuck in the upright tilt position. I cannot lower the motor to put it into the water.
I can hear the hydraulic pump working but it is just stuck at the top position. I have checked for some kind of release
valve, but cannot find anything.
Anybody got any ideas?

Thanks,
RogerC

Re: Yahama 1997 115 problems [Re: RogerC] #13566338 05/21/20 04:03 PM
Joined: Jul 2010
Posts: 933
B
boatman025 Online Content
Pro Angler
Online Content
Pro Angler
B
Joined: Jul 2010
Posts: 933
its on port side of motor pm me


Hughes Marine
3855 Osage Lane
Wylie ,Texas
Re: Yahama 1997 115 problems [Re: RogerC] #13567199 05/22/20 09:14 AM
Joined: Sep 2010
Posts: 1,583
B
boatwhisperer Online Content
Extreme Angler
Online Content
Extreme Angler
B
Joined: Sep 2010
Posts: 1,583
low on fluid ?


boatwhisperer
Re: Yahama 1997 115 problems [Re: RogerC] #13570068 05/24/20 09:35 PM
Joined: Aug 2010
Posts: 68
R
RogerC Offline OP
Outdoorsman
OP Offline
Outdoorsman
R
Joined: Aug 2010
Posts: 68
Found the valve. It did the trick. Thanks.

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3