texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
TX_PAC, Payne48, Drycreek3189, PMiller53, Lewis Miller
112889 Registered Users
Top Posters(All Time)
TexDawg 94,689
hopalong 86,723
Pilothawk 79,730
John175☮ 77,250
JDavis7873 67,398
Bigbob_FTW 64,324
Derek 🐝 64,244
Mark Perry 59,809
Tritonman 58,900
facebook
Forum Statistics
Forums62
Topics779,689
Posts9,834,193
Members112,888
Most Online36,273
Jan 23rd, 2013
Print Thread
Right side of SI not working #13557296 05/14/20 01:42 PM
Joined: Jul 2014
Posts: 546
goodman1389 Offline OP
Pro Angler
OP Offline
Pro Angler
Joined: Jul 2014
Posts: 546
The last 2 trips, the right side of my side imaging has gone black. I installed the latest update and that didn’t fix it. Any one have any experience with this. The unit is a Helix 10 mega SI G2N

Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Right side of SI not working [Re: goodman1389] #13557356 05/14/20 02:14 PM
Joined: Apr 2012
Posts: 709
T
T-Gauntt Offline
Pro Angler
Offline
Pro Angler
T
Joined: Apr 2012
Posts: 709
Transducer is likely damaged. Happened on mine a while back. Swapped the transducer out and worked like a charm.


-Taylor
Re: Right side of SI not working [Re: T-Gauntt] #13557384 05/14/20 02:33 PM
Joined: Aug 2002
Posts: 1,704
pacertom Offline
Extreme Angler
Offline
Extreme Angler
Joined: Aug 2002
Posts: 1,704
Originally Posted by T-Gauntt
Transducer is likely damaged. Happened on mine a while back. Swapped the transducer out and worked like a charm.



This 100% - same thing on mine.


A MAN WILL NEVER GO TO HIS GRAVE WISHING HE'D FISHED LESS!!
Re: Right side of SI not working [Re: goodman1389] #13557468 05/14/20 03:28 PM
Joined: Jul 2011
Posts: 2,728
D
David Burton Offline
Extreme Angler
Offline
Extreme Angler
D
Joined: Jul 2011
Posts: 2,728
Is the transducer plugged directly into the unit? First things first. Unplug and reply. See if it just got a little jiggled out of place. Then I would soft reset the unit.


David Burton
2015 Skeeter FX 21

...and down goes PhotoBucket with the new Terms of Service... I predict they will be out of business or begging for forgiveness inside a month. 6/30/2017
Re: Right side of SI not working [Re: goodman1389] #13557696 05/14/20 06:10 PM
Joined: Mar 2008
Posts: 38
J
jimmyd Offline
Outdoorsman
Offline
Outdoorsman
J
Joined: Mar 2008
Posts: 38
Just happened to mine, replaced transducer, works perfect!

Re: Right side of SI not working [Re: goodman1389] #13557711 05/14/20 06:19 PM
Joined: Oct 2005
Posts: 77,250
John175☮ Online Happy
MACHO MAN
Online Happy
MACHO MAN
Joined: Oct 2005
Posts: 77,250
The dilithium crystals get weak over time.

Re: Right side of SI not working [Re: John175☮] #13557830 05/14/20 07:36 PM
Joined: Jul 2014
Posts: 546
goodman1389 Offline OP
Pro Angler
OP Offline
Pro Angler
Joined: Jul 2014
Posts: 546
Originally Posted by John175☮
The dilithium crystals get weak over time.


This is a 4 month old unit. Got it for Christmas, installed it in January. I also don't know how the transducer would be damaged already. Haven't hit anything and there isn't really any cable exposed that would be prone to pinching, etc.

Re: Right side of SI not working [Re: goodman1389] #13557846 05/14/20 07:55 PM
Joined: Nov 2008
Posts: 5,276
C
coachallentca Online Content
TFF Celebrity
Online Content
TFF Celebrity
C
Joined: Nov 2008
Posts: 5,276
Originally Posted by goodman1389
Originally Posted by John175☮
The dilithium crystals get weak over time.


This is a 4 month old unit. Got it for Christmas, installed it in January. I also don't know how the transducer would be damaged already. Haven't hit anything and there isn't really any cable exposed that would be prone to pinching, etc.

check the wiring. I did not have mine good on the back last time and I got one side of SI not showing up


Cowboy Church bass club
Tournament Director
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3