texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Grumps 57, Buchanan61, JPearce157, Trentskies, dnnymcdnl
113945 Registered Users
Top Posters(All Time)
TexDawg 97,765
hopalong 90,760
Pilothawk 80,374
John175☮ 77,777
Bigbob_FTW 67,849
JDavis7873 67,400
Derek 🐝 65,212
Mark Perry 61,002
Tritonman 59,005
facebook
Forum Statistics
Forums62
Topics782,897
Posts9,937,838
Members113,945
Most Online36,273
Jan 23rd, 2013
Print Thread
Brake lights #13548444 05/07/20 12:31 PM
Joined: Oct 2004
Posts: 12,182
M
Mike Keenan Offline OP
TFF Guru
OP Offline
TFF Guru
M
Joined: Oct 2004
Posts: 12,182
Why would brake lights quit working and turn signals continue to work when it’s the same bulb?


R.I.P. Mike "pappy" "broken rod" Green born 07-16-62 on to better fishing 06-10-08.
www.basscat.com

Re: Brake lights [Re: Mike Keenan] #13548530 05/07/20 01:32 PM
Joined: May 2013
Posts: 417
B
Burbarry Offline
Angler
Offline
Angler
B
Joined: May 2013
Posts: 417
Might be corrosion on the break light contact. possibly bad wire or loose wire. Maybe even bad contact at the truck plug.

Re: Brake lights [Re: Mike Keenan] #13548599 05/07/20 02:17 PM
Joined: Nov 2017
Posts: 87
F
Fish2Chill 1 Offline
Outdoorsman
Offline
Outdoorsman
F
Joined: Nov 2017
Posts: 87
Check fuse panel on the tow vehicle. I have had one go out for whatever reason.

Re: Brake lights [Re: Fish2Chill 1] #13548650 05/07/20 02:49 PM
Joined: May 2013
Posts: 417
B
Burbarry Offline
Angler
Offline
Angler
B
Joined: May 2013
Posts: 417
Originally Posted by Fish2Chill 1
Check fuse panel on the tow vehicle. I have had one go out for whatever reason.


That's a good point. I had that happen one time. It was actually a fuse under the hood that was hard to trace down. I had look in the manual as the other 2 inside the truck were both fine.

Re: Brake lights [Re: Burbarry] #13549318 05/07/20 08:51 PM
Joined: Oct 2004
Posts: 12,182
M
Mike Keenan Offline OP
TFF Guru
OP Offline
TFF Guru
M
Joined: Oct 2004
Posts: 12,182
Sorry I guess I should have been more clear... it’s a 2006 Ford Expedition it’s towing nothing. It’s my girlfriends vehicle and turn signals work fine, I replaced both bulbs, so I know it’s not them.


R.I.P. Mike "pappy" "broken rod" Green born 07-16-62 on to better fishing 06-10-08.
www.basscat.com

Re: Brake lights [Re: Mike Keenan] #13549596 05/08/20 12:26 AM
Joined: Mar 2013
Posts: 855
K
Kevin R. Offline
Pro Angler
Offline
Pro Angler
K
Joined: Mar 2013
Posts: 855
If it's on the tow vehicle I would think the brake light switch is bad, or a blown fuse. But it's hard to say with out doing some checks.

Last edited by Kevin R.; 05/08/20 12:27 AM.
Re: Brake lights [Re: Kevin R.] #13551606 05/09/20 03:26 PM
Joined: Oct 2004
Posts: 12,182
M
Mike Keenan Offline OP
TFF Guru
OP Offline
TFF Guru
M
Joined: Oct 2004
Posts: 12,182
The brake light switch is a good start. But I will check fuses too


R.I.P. Mike "pappy" "broken rod" Green born 07-16-62 on to better fishing 06-10-08.
www.basscat.com

Re: Brake lights [Re: Mike Keenan] #13551637 05/09/20 03:59 PM
Joined: Feb 2006
Posts: 2,545
B
bronco71 Online Content
Extreme Angler
Online Content
Extreme Angler
B
Joined: Feb 2006
Posts: 2,545
Sounds like the brake light switch on the top of the brake pedal


1999 Triton TX21/225 Mercury Optimax
Re: Brake lights [Re: bronco71] #13553499 05/11/20 05:56 PM
Joined: Apr 2004
Posts: 10,113
S
Stump jumper Online Content
TFF Guru
Online Content
TFF Guru
S
Joined: Apr 2004
Posts: 10,113
Originally Posted by bronco71
Sounds like the brake light switch on the top of the brake pedal

+ another. I replaced on 2 Fords


2200 Bay Champ/200 Mercury Optimax
2017 Tundra TSS 4x4 Crewmax 5.7L
Re: Brake lights [Re: Mike Keenan] #13569706 05/24/20 03:29 PM
Joined: Mar 2013
Posts: 855
K
Kevin R. Offline
Pro Angler
Offline
Pro Angler
K
Joined: Mar 2013
Posts: 855
Did your problem get fixed?

Re: Brake lights [Re: Mike Keenan] #13569891 05/24/20 06:37 PM
Joined: Feb 2015
Posts: 3,992
F
Flippin-Out Offline
TFF Team Angler
Offline
TFF Team Angler
F
Joined: Feb 2015
Posts: 3,992
Originally Posted by Mike Keenan
Sorry I guess I should have been more clear... it’s a 2006 Ford Expedition it’s towing nothing. It’s my girlfriends vehicle and turn signals work fine, I replaced both bulbs, so I know it’s not them.

Unless the vehicle has amber turn signals, replacing bulbs was a waste of money - the same filament that is the turn slgnal is also the brake filament. If one works and the other doesn't, the problem isn't the filament in the bulb. I don't remember which type that vehicle has. Another hint is that rarely would 2 bulbs decide to fail at the same time. Look for something in common.

Check the brake switch on the pedal stem by removing the wiring connector and jumping the two contacts together (with the vehicle on/running).
Check the owner's manual to see where the brake circuit fuse is located and check that. If it's blown, don't be surprised if it blows again since they blow for a reason.
My bet is on the switch as a failure point.

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3