texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Fresh_Salt84, RicHoll, day tripper, ford1213, Rodfather708
115583 Registered Users
Top Posters(All Time)
TexDawg 103,171
hopalong 97,572
Pilothawk 80,978
John175☮ 79,400
Bigbob_FTW 74,717
JDavis7873 67,408
Derek 🐝 66,772
Mark Perry 63,084
Forum Statistics
Forums61
Topics1,152,183
Posts15,753,538
Members140,583
Most Online36,273
Jan 23rd, 2013
Print Thread
Rate Thread
Welsh #13525732 04/20/20 02:07 AM
Joined: Nov 2019
Posts: 3,350
C
Chug-bug-bang1 Offline OP
TFF Team Angler
OP Offline
TFF Team Angler
C
Joined: Nov 2019
Posts: 3,350
Water temps?

Plant back running again?

Haven’t been in months


Hey pull my finger 👉🏻💨
Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Welsh [Re: Chug-bug-bang1] #13525776 04/20/20 02:35 AM
Joined: Jun 2005
Posts: 1,000
J
jfdawson Online Happy
Extreme Angler
Online Happy
Extreme Angler
J
Joined: Jun 2005
Posts: 1,000
I was there Saturday. Water temps were 64-67. Plant was not running. Hydrilla is growing everywhere from 1-12'. North is completely choked out with Hydrila. You can still fish it but it's crazy thick.

JD

Re: Welsh [Re: jfdawson] #13526182 04/20/20 01:43 PM
Joined: Mar 2007
Posts: 14,181
F
forkduc Offline
TFF Guru
Offline
TFF Guru
F
Joined: Mar 2007
Posts: 14,181
Pipe from Pines running again?

Re: Welsh [Re: Chug-bug-bang1] #13526254 04/20/20 02:22 PM
Joined: Jun 2005
Posts: 1,001
danceswithbass Offline
Extreme Angler
Offline
Extreme Angler
Joined: Jun 2005
Posts: 1,001
Heard from a friend they were chomping pretty good a couple of weeks ago

Previous Thread
Index
Next Thread

© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3