texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jjgray, tgray, Zhiggy, FF1437, ccr622
112855 Registered Users
Top Posters(All Time)
TexDawg 94,590
hopalong 86,574
Pilothawk 79,701
JDavis7873ฎ 67,398
Bigbob_FTW 64,156
Mark Perry 59,771
Tritonman 58,900
facebook
Forum Statistics
Forums62
Topics779,302
Posts9,828,980
Members112,855
Most Online36,273
Jan 23rd, 2013
Print Thread
Welsh #13525732 04/20/20 02:07 AM
Joined: Nov 2019
Posts: 1,352
C
Chug-bug-bang1 Online Sick OP
Extreme Angler
OP Online Sick
Extreme Angler
C
Joined: Nov 2019
Posts: 1,352
Water temps?

Plant back running again?

Havenโ€™t been in months


Hey pull my finger ๐Ÿ‘‰๐Ÿป๐Ÿ’จ
Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Welsh [Re: Chug-bug-bang1] #13525776 04/20/20 02:35 AM
Joined: Jun 2005
Posts: 981
J
jfdawson Offline
Pro Angler
Offline
Pro Angler
J
Joined: Jun 2005
Posts: 981
I was there Saturday. Water temps were 64-67. Plant was not running. Hydrilla is growing everywhere from 1-12'. North is completely choked out with Hydrila. You can still fish it but it's crazy thick.

JD

Re: Welsh [Re: jfdawson] #13526182 04/20/20 01:43 PM
Joined: Mar 2007
Posts: 13,287
F
forkduc Online Content
TFF Guru
Online Content
TFF Guru
F
Joined: Mar 2007
Posts: 13,287
Pipe from Pines running again?

Re: Welsh [Re: Chug-bug-bang1] #13526254 04/20/20 02:22 PM
Joined: Jun 2005
Posts: 919
danceswithbass Online Content
Pro Angler
Online Content
Pro Angler
Joined: Jun 2005
Posts: 919
Heard from a friend they were chomping pretty good a couple of weeks ago

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3