texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
patrickhail1, Bradbtx, Jblaza, Rich12, Rjbowl800
113182 Registered Users
Top Posters(All Time)
TexDawg 95,443
hopalong 87,379
Pilothawk 79,876
John175☮ 77,538
JDavis7873 67,398
Bigbob_FTW 65,342
Derek 🐝 64,365
Mark Perry 60,180
Tritonman 58,915
facebook
Forum Statistics
Forums62
Topics782,403
Posts9,871,566
Members113,182
Most Online36,273
Jan 23rd, 2013
Print Thread
Merc 225 EFI Fuel Issues? #13511730 04/10/20 01:57 PM
Joined: Oct 2017
Posts: 65
h^10 Offline OP
Outdoorsman
OP Offline
Outdoorsman
Joined: Oct 2017
Posts: 65
I have 97 mercury 225 efi, recently it has been acting up. It will usually start right up when i get to the lake and it will either run fine for that first run or it will start getting quieter and quieter and then eventually die. Then after the first couple spot moves it wont want to start easy again. My guesses would be fuel filters(hopefully) or fuel pump on the motor. Could also be ethanol rotted fuel lines?

Last edited by h^10; 04/10/20 02:21 PM.
Re: Merc 225 EFI Fuel Issues? [Re: h^10] #13521098 04/16/20 07:54 PM
Joined: Jan 2011
Posts: 3,542
PlanoKeith Offline
TFF Team Angler
Offline
TFF Team Angler
Joined: Jan 2011
Posts: 3,542
it may need the new ethanol resistant fuel lines. Could be they are clogging up fuel filter


Keith smile

Re: Merc 225 EFI Fuel Issues? [Re: h^10] #13522526 04/17/20 06:01 PM
Joined: Jul 2010
Posts: 938
B
boatman025 Offline
Pro Angler
Offline
Pro Angler
B
Joined: Jul 2010
Posts: 938
If you see any of your fuel line coming apart you will want to check your fuel pump for pieces


Hughes Marine
3855 Osage Lane
Wylie ,Texas
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3