texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Fishnobi, 1bg, rbishop57, CoreyAbel, MckinneyCat
113446 Registered Users
Top Posters(All Time)
TexDawg 96,154
hopalong 88,400
Pilothawk 79,965
John175☮ 77,777
JDavis7873 67,400
Bigbob_FTW 66,029
Derek 🐝 64,570
Mark Perry 60,415
Tritonman 58,942
facebook
Forum Statistics
Forums62
Topics776,875
Posts9,852,052
Members113,444
Most Online36,273
Jan 23rd, 2013
Print Thread
Lithium Pros Help #13392112 01/04/20 01:34 AM
Joined: May 2013
Posts: 24
regbu Offline OP
Outdoorsman
OP Offline
Outdoorsman
Joined: May 2013
Posts: 24
Is there anyone using Lithium Pros Lithium Batteries on TFF?

Thank you in advance for the help.

I have a 2018 24v trolling battery from Lithium Pros that is connected to an M1226 charger (red version). The charger recently stopped working altogether, with no lights showing on the "Mode" display. Before I remove the charger and return the charger to Lithium Pros, has anyone had a similar issue? If you have had a similar issue, was there any fix?

Thank you.

Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Lithium Pros Help [Re: regbu] #13393053 01/05/20 01:54 AM
Joined: Aug 2018
Posts: 3
W
Wash84 Offline
Green Horn
Offline
Green Horn
W
Joined: Aug 2018
Posts: 3
Yes Ive been running lithium pros for about five years and from what I remember they have had nothing but problems with the Red on board charger i would send it back and buy the blue charger that’s been around for years.

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3