texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Fish dad, Fiiishallday, floor, HPwillmabus, DFentress
111328 Registered Users
Top Posters(All Time)
TexDawg 91,801
hopalong 81,921
Pilothawk 78,728
John175☮ 73,240
JDavis7873 67,397
Derek 🐝 63,037
Bigbob_FTW 59,335
Tritonman 58,763
Mark Perry 56,917
facebook
Forum Statistics
Forums60
Topics761,259
Posts9,568,404
Members111,328
Most Online36,273
Jan 23rd, 2013
Print Thread
2013 Merc 90 optimax #13289981 09/22/19 09:13 PM
Joined: Apr 2009
Posts: 70
J
JSouther Offline OP
Outdoorsman
OP Offline
Outdoorsman
J
Joined: Apr 2009
Posts: 70
Help......boat in limp mode with intermittent beep. Manual shows cooling or oil problem. Oil tank is full and flushed motor several times and is spitting water. Decided to change spark plugs fuel filter, air filter cleaned manual lift pump and tested high and low fuel pump. Cleaned injectors still same thing. Rough idle won’t go over 2500rpm and beep still there. I think might be bad sensor or something. Any ideas? Can a bad battery cause this? Boat currently at shop to get plugged up to computer but they are two weeks out.

Re: 2013 Merc 90 optimax [Re: JSouther] #13289986 09/22/19 09:28 PM
Joined: Apr 2009
Posts: 70
J
JSouther Offline OP
Outdoorsman
OP Offline
Outdoorsman
J
Joined: Apr 2009
Posts: 70
Sorry meant to post on boats and motors

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3