texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jhobbs1970, Packrattusnongratus, IMightKnowSomething, wesoftexas, Cruzcab
111156 Registered Users
Top Posters(All Time)
TexDawg 91,581
hopalong 81,544
Pilothawk 78,600
John175☮ 72,741
JDavis7873 67,397
Derek 🐝 62,825
Tritonman 58,747
Bigbob_FTW 58,454
Mark Perry 56,520
facebook
Forum Statistics
Forums60
Topics759,005
Posts9,535,520
Members111,156
Most Online36,273
Jan 23rd, 2013
Print Thread
2000 150 VMAX WATER PUMP ETC #13258906 08/25/19 05:36 AM
Joined: Nov 2003
Posts: 244
Y
YAMADOGGY Offline OP
Outdoorsman
OP Offline
Outdoorsman
Y
Joined: Nov 2003
Posts: 244
BOUGHT NEW 2000 CHAMPION W NEW 2000 VMAX BEEN GREAT.......HAD IMPELLER REPLACED 2017 ALL WAS FINE, ABOUT 5 HRS ON IMPELLER, NEVER START WHEN NOT IN WATER..........SO GETTING IT READY FOR FISHING AGAIN I START ENGINE SUBMERGED IN TROUGH............NO PEE HOLE OUTLET SO I SHUT DOWN.........HOOKED FLUSH SET UP W HOSE GOING AND ENGINE OFF AND ELECTRONIC COVER OFF TO ACCESS HOSE AND PORT COMING FROM BLOCK TO COWL PEE HOLE, HOSE WAS CLEAR, FINALLY GOT WATER FROM ENGINE AFTER A BURB/GURGLE SOUND. START AGAING TO DAY SUBMERGERED IN TROUGH UP PAST LOWER WATER INTAKES AND NO PEEING AT IDLE, SHUT DOWN, HOOKED FLUSH BACK ON AND STARTED GOOD FLOW, LET IDLE FOR 5 MIN TOOK FLUSH HOSE OFF AND RECONNECTED TO LOWER STOW POINT.....ALL SEEMED TO KEEP FLOWING/PEEING FOR 10 MIN IDLE..............SHUT DOWN AND STARTED 10 MIN LATER NO PEEING AND SAME DEAL??????????????????? ANY IDEAS ? NEVER HAVE HAD ANY WATER OUTLET PROBLEMS THX

Re: 2000 150 VMAX WATER PUMP ETC [Re: YAMADOGGY] #13259738 08/26/19 06:13 AM
Joined: Nov 2003
Posts: 244
Y
YAMADOGGY Offline OP
Outdoorsman
OP Offline
Outdoorsman
Y
Joined: Nov 2003
Posts: 244
WATER IS ABOVE LOWER UNIT PICK UP BUT NOT ABOVE CAVITATION PLATE, GONNA TRY DEEPER TROUGH OR JUST TAKE TO RAMP AND SUBMERGE AND SEE

Re: 2000 150 VMAX WATER PUMP ETC [Re: YAMADOGGY] #13261048 08/27/19 04:22 AM
Joined: Nov 2003
Posts: 244
Y
YAMADOGGY Offline OP
Outdoorsman
OP Offline
Outdoorsman
Y
Joined: Nov 2003
Posts: 244
put muss on and had water in 3 sec thx

Re: 2000 150 VMAX WATER PUMP ETC [Re: YAMADOGGY] #13261049 08/27/19 04:22 AM
Joined: Nov 2003
Posts: 244
Y
YAMADOGGY Offline OP
Outdoorsman
OP Offline
Outdoorsman
Y
Joined: Nov 2003
Posts: 244
muffs

Re: 2000 150 VMAX WATER PUMP ETC [Re: YAMADOGGY] #13262144 08/28/19 04:57 AM
Joined: Nov 2003
Posts: 244
Y
YAMADOGGY Offline OP
Outdoorsman
OP Offline
Outdoorsman
Y
Joined: Nov 2003
Posts: 244
PLZ DELETE

Re: 2000 150 VMAX WATER PUMP ETC [Re: YAMADOGGY] #13265031 08/30/19 04:00 PM
Joined: Aug 2017
Posts: 135
D
Dug71 Offline
Outdoorsman
Offline
Outdoorsman
D
Joined: Aug 2017
Posts: 135
using water hose connection or muffs on it will not truly test it out because the water will still come out the tattle tail even with the motor off.

Ive got that engine and you have to submerge that lower unit completely to get the impeller to pick up water.

I went through that very thing.

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3