texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
turbodog007, Drycreek, spidermanscape, ItekTackle, Sabre
111012 Registered Users
Top Posters(All Time)
TexDawg 91,412
hopalong 81,125
Pilothawk 78,483
John175☮ 72,371
JDavis7873® 67,395
Derek 🐝 62,655
Tritonman 58,722
Bigbob_FTW 57,782
Mark Perry 56,233
facebook
Forum Statistics
Forums60
Topics756,960
Posts9,505,069
Members111,012
Most Online36,273
Jan 23rd, 2013
Print Thread
Lowrance 9Ti GPS #13228186 07/29/19 02:03 AM
Joined: Dec 2015
Posts: 437
T
TxRanger1 Offline OP
Angler
OP Offline
Angler
T
Joined: Dec 2015
Posts: 437
Was out on the lake and decided to run up the river. GPS was working just fine following old trails and making new ones. Stopped and fished a couple hours and got ready to head back. Pulled up map and everything looked great for a minute then everything started to look funny. I was following a trail back and it stared showing me going slightly to right. Came up to and island and it showed me going over land and I am pretty sure I was still in the river. Got back to the main lake and the direction was wrong and was showing me going to the right maybe 100 yards or so off from where I was. I run the same path every time and it was off.Is there something I can do to get it back to normal?
Thanks

Re: Lowrance 9Ti GPS [Re: TxRanger1] #13230176 07/30/19 05:39 PM
Joined: Oct 2005
Posts: 725
Rob Jasper Lowrance Pro-Staff Offline
Pro Angler
Offline
Pro Angler
Joined: Oct 2005
Posts: 725
Do you have an Elite Ti first generation or the new Elite Ti2 second generation? Have you been out on the water since this happened, if so did GPS work properly?


Rob Jasper
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3