texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Texx23, Kent Vanderheiden, delder18, kimneal, Bobby A
111310 Registered Users
Top Posters(All Time)
TexDawg 91,775
hopalong 81,900
Pilothawk 78,705
JDavis7873ģ 67,397
Derek 🐝 63,030
Bigbob_FTW 59,247
Tritonman 58,760
Mark Perry 56,854
facebook
Forum Statistics
Forums60
Topics760,983
Posts9,564,832
Members111,310
Most Online36,273
Jan 23rd, 2013
Print Thread
Quicksilver 3000 throttle problem #13223955 07/24/19 03:03 AM
Joined: May 2018
Posts: 50
C
Capshaw42 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: May 2018
Posts: 50
My boat was running good today and then all of the sudden I went to take off and it wouldnít go but .5mph forward and backward. The throttle would go down past parallel both ways but no juice. [Linked Image]
I have taken it apart but donít know where to go from there. Should I replace cables? Put it back together and try again? I canít find solutions anywhere online. Has anyone had the same problem? Thanks


Brady Capshaw
Re: Quicksilver 3000 throttle problem [Re: Capshaw42] #13224247 07/24/19 03:45 PM
Joined: Jun 2004
Posts: 1,486
O
OPTI Offline
Extreme Angler
Offline
Extreme Angler
O
Joined: Jun 2004
Posts: 1,486
Check the plastic barrels on cables have seen them split and cable sleeve will slide in barrel have it mostly on the barrel anchors at control box. flush mount boxes are a pain to remove by looking at picture it a Ranger will more than likely have to come out the front they are a booger bear.....OPTI

Re: Quicksilver 3000 throttle problem [Re: Capshaw42] #13224275 07/24/19 04:16 PM
Joined: May 2018
Posts: 50
C
Capshaw42 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: May 2018
Posts: 50
Thanks! Iím about to dive in when I get home in a minute. Iíll keep you updated. Hopefully itís not too complicated and I can get it fixed.


Brady Capshaw
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3