texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
RPerry, Matilda's Lakeside Store & RV, Buckchaser, thereelclayton, Theview
111036 Registered Users
Top Posters(All Time)
TexDawg 91,440
hopalong 81,190
Pilothawk 78,500
John175☮ 72,424
JDavis7873® 67,395
Derek 🐝 62,675
Tritonman 58,725
Bigbob_FTW 57,861
Mark Perry 56,259
facebook
Forum Statistics
Forums60
Topics757,271
Posts9,509,404
Members111,036
Most Online36,273
Jan 23rd, 2013
Print Thread
Humminbird Helix 10 G2N Malfunction? #13216276 07/16/19 02:22 PM
Joined: Feb 2012
Posts: 142
C
csbrad58 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: Feb 2012
Posts: 142
The unit for some reason is showing more definition on the right side of the side imaging better than the left? Also, it seems the down imaging isn't showing its highest quality?

Anybody that's had trouble with this? I was leaning towards the transducer getting hit by a stump.


ISAIAH 40:31
Bass Fishing Ad
Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216305 07/16/19 02:39 PM
Joined: Jun 2007
Posts: 417
ToadThrower Online Content
Angler
Online Content
Angler
Joined: Jun 2007
Posts: 417
Did you check the transducer to see that is is level...had that issue from hitting a stump and twisted the transducer...also the sonar depth readings were wacky as well..straightened it out and fixed that issue...hope that it is an easy fix...

Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216317 07/16/19 02:45 PM
Joined: Feb 2012
Posts: 142
C
csbrad58 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: Feb 2012
Posts: 142
I remember looking at the transducer and checking if it had moved at all but I don't remember checking to see if it is twisted. I mean the image isn't bad but I've looked at that screen long enough to know something has changed. I did notice some rough marks on it but no cracks. Could that have messed with the image?

I have also updated the unit.


ISAIAH 40:31
Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216356 07/16/19 03:08 PM
Joined: Jun 2007
Posts: 417
ToadThrower Online Content
Angler
Online Content
Angler
Joined: Jun 2007
Posts: 417
If it is level to the bottom of the boat...then you may have a transducer problem...hook your head unit, if you can to another working transducer and see if it has the same image...if it does it is the head unit....if it doesnt it is the transducer. I had some issues with mine on side image it was a faulty head unit...I have two Gen2 Helix 9s on my boat so it is easy to swap them to determine if the problem is in the head unit or transducer. Good luck...

Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216552 07/16/19 06:07 PM
Joined: Feb 2012
Posts: 142
C
csbrad58 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: Feb 2012
Posts: 142
Well, the next question if anyone is reading this... Will anyone on here let me put my unit on their boat and see if it is the transducer that's messed up?


ISAIAH 40:31
Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216633 07/16/19 07:36 PM
Joined: Oct 2008
Posts: 363
J
jackwabbit Offline
Angler
Offline
Angler
J
Joined: Oct 2008
Posts: 363
Where are you located?

Re: Humminbird Helix 10 G2N Malfunction? [Re: csbrad58] #13216669 07/16/19 08:11 PM
Joined: Jan 2018
Posts: 33
C
ClarkC Offline
Outdoorsman
Offline
Outdoorsman
C
Joined: Jan 2018
Posts: 33
After having my Helix 10 for about 6 or 7 months I noticed the left side of side imaging losing much of its signal. My motor is not on a jack plate and I finally realized that if it was trimmed all the way down, it was blocking some of the signal. I now make sure the motor is trimmed up a little if I am going to idle around and look at stuff.

Re: Humminbird Helix 10 G2N Malfunction? [Re: jackwabbit] #13216741 07/16/19 09:16 PM
Joined: Feb 2012
Posts: 142
C
csbrad58 Offline OP
Outdoorsman
OP Offline
Outdoorsman
C
Joined: Feb 2012
Posts: 142
Tyler, Texas


ISAIAH 40:31
Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3