texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
EAWeiss, Cat-Fish333, river runner 1, Popping shorty, Find your own fish
112035 Registered Users
Top Posters(All Time)
TexDawg 92,820
hopalong 83,686
Pilothawk 79,342
John175☮ 75,295
JDavis7873 67,398
Derek 🐝 63,724
Bigbob_FTW 62,093
Tritonman 58,836
Mark Perry 58,494
facebook
Forum Statistics
Forums62
Topics770,233
Posts9,701,551
Members112,035
Most Online36,273
Jan 23rd, 2013
Print Thread
Helix 10 Issue #13199338 06/29/19 03:10 AM
Joined: Feb 2010
Posts: 3,301
R
RedRaider3933 Offline OP
TFF Team Angler
OP Offline
TFF Team Angler
R
Joined: Feb 2010
Posts: 3,301
My tournament partner has an issue with his front units. In the last two weeks he has had 2 different Helix 10s completely fry and dont know what the issue is. They will work fine then all of the sudden completely stop working. Try to plug them into the console power (runs a Helix 12 at the console) and it wont power up there either. Seems like both 10s are fried. Any idea what might cause this? He has an Ultrex and uses the internal transducer if it makes a difference. Seems like a possible wiring issue but has ran the front graph as is for close to 2 years. Just now having the problem.


Go Tech
Bass Fishing Ad
Re: Helix 10 Issue [Re: RedRaider3933] #13199433 06/29/19 11:16 AM
Joined: Apr 2004
Posts: 308
I
irbf Online Shocked
Angler
Online Shocked
Angler
I
Joined: Apr 2004
Posts: 308
Is the power to front on a fused line and what gauge is it?


2008 BassCat Puma, 250 ProXS
Re: Helix 10 Issue [Re: RedRaider3933] #13199477 06/29/19 12:34 PM
Joined: Oct 2007
Posts: 3,430
5
5Redman8 Online Content
TFF Team Angler
Online Content
TFF Team Angler
5
Joined: Oct 2007
Posts: 3,430
Is there anything visible when they fry.

My 12 has fried 3 times already in less than a year. HB has sent me a new head unit each time.

Shut Up and Fish did my wiring.

I think HB has an ongoing problem with these and they are not owning up to it.

This is what mine looks like when fried.....
[Linked Image]

Last edited by 5Redman8; 06/29/19 02:17 PM.

Originally Posted by Dubee
People wanting to learn, watching idiots that don't know what they are doing doesn't help anyone.
Re: Helix 10 Issue [Re: 5Redman8] #13199539 06/29/19 02:02 PM
Joined: Oct 2004
Posts: 12,020
M
Mike Keenan Online Content
TFF Guru
Online Content
TFF Guru
M
Joined: Oct 2004
Posts: 12,020
Is it wired to the main battery or wired to a fuse block? I had similar issues up until shut up and fish rewired all my units to the cranking battery. When mine were installed by a local shop I requested mine to be all hard wired to the cranking battery per Humminbird guidelines. Instead they wired my Helix 9 to a power source on the front deck and the Helix 10 to a fuse block under the console only to save time, they only cared that both units worked when they left the shop. Both units had nothing but issues until they were wired correctly. So I had to pay twice to have my units done correctly.

Do your buddies units come with the boat or did he have installed by a local shop and have the same issues I had?


R.I.P. Mike "pappy" "broken rod" Green born 07-16-62 on to better fishing 06-10-08.
www.basscat.com

Re: Helix 10 Issue [Re: RedRaider3933] #13199619 06/29/19 04:03 PM
Joined: Feb 2010
Posts: 3,301
R
RedRaider3933 Offline OP
TFF Team Angler
OP Offline
TFF Team Angler
R
Joined: Feb 2010
Posts: 3,301
That picture is what the first one looked like. The second one is randomly working again today. I believe it is wired to the fuse panel under the driver console and not straight to the cranking battery.


Go Tech
Re: Helix 10 Issue [Re: RedRaider3933] #13199621 06/29/19 04:06 PM
Joined: Oct 2007
Posts: 3,430
5
5Redman8 Online Content
TFF Team Angler
Online Content
TFF Team Angler
5
Joined: Oct 2007
Posts: 3,430
Feel of the unit and see if it is overheating.

Mine would get super hot. I could let it cool down and it would reboot and work for a bit but eventually it just died.

I feel like the true test will be in August when I go fishing to see if the newest one will last.

These are my first and last HB units. Should have just stuck with Lowrance.


Originally Posted by Dubee
People wanting to learn, watching idiots that don't know what they are doing doesn't help anyone.
Re: Helix 10 Issue [Re: 5Redman8] #13199669 06/29/19 05:05 PM
Joined: Jan 2009
Posts: 607
A
aggieangler03 Offline
Pro Angler
Offline
Pro Angler
A
Joined: Jan 2009
Posts: 607
Originally Posted by 5Redman8
Feel of the unit and see if it is overheating.

Mine would get super hot. I could let it cool down and it would reboot and work for a bit but eventually it just died.

I feel like the true test will be in August when I go fishing to see if the newest one will last.

These are my first and last HB units. Should have just stuck with Lowrance.


My new Live 9s didnt work straight out the box. I got one back in 2 weeks and still dont have the other one. They wont tell me what was wrong either. Just sent me a replacement. Should have stuck with Humminbird......

Re: Helix 10 Issue [Re: RedRaider3933] #13200003 06/30/19 01:48 AM
Joined: Oct 2004
Posts: 12,020
M
Mike Keenan Online Content
TFF Guru
Online Content
TFF Guru
M
Joined: Oct 2004
Posts: 12,020
Originally Posted by RedRaider3933
That picture is what the first one looked like. The second one is randomly working again today. I believe it is wired to the fuse panel under the driver console and not straight to the cranking battery.



Humminbird recommends straight to the cranking battery for all units.


R.I.P. Mike "pappy" "broken rod" Green born 07-16-62 on to better fishing 06-10-08.
www.basscat.com

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3