texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
ChefDave, inshorefisherman, anglperrone, QuijasL71, RS1X
115972 Registered Users
Top Posters(All Time)
TexDawg 104,550
hopalong 100,204
Pilothawk 81,269
John175☮ 80,024
Bigbob_FTW 76,338
JDavis7873 67,408
Derek 🐝 67,048
Mark Perry 64,084
Forum Statistics
Forums61
Topics1,157,460
Posts15,829,053
Members140,972
Most Online36,273
Jan 23rd, 2013
Print Thread
Helix Depth/Sonar Issues #13172455 05/31/19 10:07 PM
Joined: Dec 2010
Posts: 750
5
5PounderOnAFrog Offline OP
Pro Angler
OP Offline
Pro Angler
5
Joined: Dec 2010
Posts: 750
Posting this here because Ill die of old age before I get a response on the equipment section. My helix (gen 1) randomly stopped giving me a depth reading and the sonar/si/di screens are all blank. Transducer is pinging and I also hooked it up to the transducer for my unit at the bow (which is working) and its doing the same thing there so the problem seems to be in the head unit. Im also still getting the temp reading. Tried factory reset and still nothing. Anyone have any ideas? Thanks

Edited to add: I got caught in a storm about a month ago and had some moisture in the screen afterwards. Unit worked fine for a couple trips but now this popped up. Seems unlikely that water damage would cause this one single issue and nothing else but I suppose its possible.


[Linked Image]
[Linked Image]

Last edited by 5PounderOnAFrog; 05/31/19 10:13 PM.
Moritz Chevrolet - 9101 Camp Bowie W Blvd, Fort Worth, TX - Monte Coon (817) 696-2003
Re: Helix Depth/Sonar Issues [Re: 5PounderOnAFrog] #13172463 05/31/19 10:19 PM
Joined: Jul 2012
Posts: 1,340
M
MagFluker Offline
Extreme Angler
Offline
Extreme Angler
M
Joined: Jul 2012
Posts: 1,340
Make sure your connection in the back of the unit is right. I had my transducer wire pop out on me once, just got loose.

Never thought my 1000th post would be a trouble shooting comment haha offtopic

Last edited by MagFluker; 05/31/19 10:20 PM. Reason: 1000th post!

Kyle in NC

PB 11.1



Re: Helix Depth/Sonar Issues [Re: 5PounderOnAFrog] #13172467 05/31/19 10:25 PM
Joined: Dec 2010
Posts: 750
5
5PounderOnAFrog Offline OP
Pro Angler
OP Offline
Pro Angler
5
Joined: Dec 2010
Posts: 750
Cleaned the connections and reapplied dielectric grease. Still nothing. Appreciate the suggestion though.

Re: Helix Depth/Sonar Issues [Re: 5PounderOnAFrog] #13172535 05/31/19 11:40 PM
Joined: Mar 2005
Posts: 702
B
Basshead21 Offline
Pro Angler
Offline
Pro Angler
B
Joined: Mar 2005
Posts: 702
Send it in to Humminbird. If they cant fix it they will send you a new one. The cost is around 280.00 dollars. Cheaper than a new one. Their return is 3-5 business days.

Previous Thread
Index
Next Thread

© 1998-2021 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.3