texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
ST1300, RGTXSKEETER, Bassdonjarr, NorthwestNative, condorstan
109743 Registered Users
Top Posters(All Time)
TexDawg 90,458
hopalong 79,255
Pilothawk 77,918
John175® 70,648
JDavis7873® 67,394
Derek 🐝 61,955
Tritonman 58,516
Mark Perry 55,397
LoneStarSon® 54,921
facebook
Forum Statistics
Forums60
Topics742,367
Posts15,320,210
Members109,743
Most Online36,273
Jan 23rd, 2013
Print Thread
helix 7 gps #12689921
03/26/18 06:24 PM
03/26/18 06:24 PM
Joined: Aug 2007
Posts: 104
R
rmorris Offline OP
Outdoorsman
rmorris  Offline OP
Outdoorsman
R

Joined: Aug 2007
Posts: 104
I bought a new helix 7 last August. I finally got the lakemaster card for right after the new year started. The gps takes forever to find me. Sometimes I have to take the card out and let the maps that are already on unit find me. I then put the card back in and it goes over to the lakemaster card. Saturday on Cypress it finally found me but the screen was black. It followed me all day with a black screen and a red line all over it. Can anybody give me any suggestions on what could be wrong or how to fix this problem. Thanks in advance for any help with this matter.

Re: helix 7 gps [Re: rmorris] #12689928
03/26/18 06:29 PM
03/26/18 06:29 PM
Joined: Jul 2014
Posts: 3,693
Arlington
B
Bobby Milam Offline
TFF Team Angler
Bobby Milam  Offline
TFF Team Angler
B

Joined: Jul 2014
Posts: 3,693
Arlington
Remove the card and blow into slot. Check contacts on card to see if they are clean. If not use an eraser to clean. Look at settings and see if it is turned on auto for selecting map card

Previous Thread
Index
Next Thread


© 1998-2019 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
Powered by UBB.threads™ PHP Forum Software 7.7.1