texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
scott100, Monty97, MiggyFishing, PierceBull12, Hawk1997
109276 Registered Users
Top Posters(All Time)
TexDawg 90,112
hopalong 78,911
Pilothawk 77,534
John175® 69,831
JDavis7873® 67,393
Derek 🐝 61,676
Tritonman 58,395
LoneStarSon® 54,816
Mark Perry 54,792
facebook
Forum Statistics
Forums60
Topics777,156
Posts13,000,569
Members109,276
Most Online36,273
Jan 23rd, 2013
Print Thread
hummingbird helix 5 problem. #12600267
01/29/18 05:30 PM
01/29/18 05:30 PM
Joined: Jun 2017
Posts: 322
cedar hill tx.
sae Offline OP
Angler
sae  Offline OP
Angler

Joined: Jun 2017
Posts: 322
cedar hill tx.



h. bird 5 di.si gen1.

Went out sunday to look at humps.first 30 min. sonar, di., andside image o.k.[ for what a 5 will do )
Then d.i. and s. i. went black .after 10 or 15 min. a narrow green stripe in the middle of d.i and s. i. screen.
Iwas using the green pallet.P. Oed, I hauled butt back to my cove.As I came off plane s.i. and di].i. started to work ?

Re: hummingbird helix 5 problem. [Re: sae] #12601110
01/30/18 01:30 AM
01/30/18 01:30 AM
Joined: May 2016
Posts: 261
LakeForkBoatAccessories Offline
Angler
LakeForkBoatAccessories  Offline
Angler

Joined: May 2016
Posts: 261
Check your transducer cable where it plugs into the unit. Check the ears on the cable organizer. Also check the tabs on the unit that hold the cables to the unit. If all is good maybe time for a transducer. Good luck


Light’m Up

Steve Smith
661 -706 -1569
Lake Fork Boat Accessories
Re: hummingbird helix 5 problem. [Re: sae] #12601133
01/30/18 01:37 AM
01/30/18 01:37 AM
Joined: Jun 2017
Posts: 322
cedar hill tx.
sae Offline OP
Angler
sae  Offline OP
Angler

Joined: Jun 2017
Posts: 322
cedar hill tx.
Thank,s l.f. will check this next trip.

Re: hummingbird helix 5 problem. [Re: LakeForkBoatAccessories] #12601342
01/30/18 02:41 AM
01/30/18 02:41 AM
Joined: Nov 2010
Posts: 4,173
Charlottesville, Va
W
Wayne P. Online content
TFF Team Angler
Wayne P.  Online Content
TFF Team Angler
W

Joined: Nov 2010
Posts: 4,173
Charlottesville, Va
Originally Posted By: LakeForkBoatAccessories
Check your transducer cable where it plugs into the unit. Check the ears on the cable organizer. Also check the tabs on the unit that hold the cables to the unit. If all is good maybe time for a transducer. Good luck


There is no "cable organizer" with a Helix 5 or Helix 7. They have individual friction fit receptacles for the cable plugs. Just make sure the transducer plug is firmly inserted so it bottoms out.


Humminbird Helix 12 CHIRP SI, 1198c SI, 1198c SI, ONIX 10 SI NT, Helix 7 CHIRP SI GPS G2, SOLIX 12 SI, 360, RC-1
Re: hummingbird helix 5 problem. [Re: sae] #12608368
02/03/18 12:32 PM
02/03/18 12:32 PM
Joined: Jun 2017
Posts: 322
cedar hill tx.
sae Offline OP
Angler
sae  Offline OP
Angler

Joined: Jun 2017
Posts: 322
cedar hill tx.
thank's L. F. B. and Wayne p
Pulled the head and both cables had pulled some. Reset and took a short run,all good.
Will have to keep an eye on it.The caps don't fit very tight and my boat is a rough ride.

Previous Thread
Index
Next Thread


© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
UBB.threads™ 7.6.2