texasfishingforum.com logo
Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Hawk1997, R.Tillman, mrhellcat, shadyman, Brasberry
109272 Registered Users
Top Posters(All Time)
TexDawg 90,110
hopalong 78,911
Pilothawk 77,528
John175® 69,823
JDavis7873® 67,393
Derek 🐝 61,670
Tritonman 58,393
LoneStarSon® 54,816
Mark Perry 54,780
facebook
Forum Statistics
Forums60
Topics777,065
Posts12,999,434
Members109,272
Most Online36,273
Jan 23rd, 2013
Print Thread
2003 Mercury Optimax Issues #12330046
07/08/17 10:04 PM
07/08/17 10:04 PM
Joined: Nov 2009
Posts: 31
A
Alfredo Offline OP
Outdoorsman
Alfredo  Offline OP
Outdoorsman
A

Joined: Nov 2009
Posts: 31
I had a new lower unit installed in April. Have had water pump issues ever since it was installed. I have taken it back twice and all they ever say is we just had to clean it out. I believed that after the first time since I had just been to Palestine! However, it keeps happening and it never did prior to the lower unit replacement.

I just flushed it myself and it is not flowing properly and has a lower psi at idling RPMs than previously. Anyone have any ideas....

On a separate note, last time I went out, the engine would rev to high RPMs at start up and then back off and run fine.... up until the the ear piercing constant alarm would come on alerting me to the PSI problem!

Any thoughts on how to proceed would be appreciated. Thanks.

Re: 2003 Mercury Optimax Issues [Re: Alfredo] #12330119
07/08/17 10:57 PM
07/08/17 10:57 PM
Joined: Apr 2014
Posts: 334
Keller, TX
JDJ01 Offline
Angler
JDJ01  Offline
Angler

Joined: Apr 2014
Posts: 334
Keller, TX
May sound dumb but my first thought is the water pump "key" that sits in a tiny void on the shaft essentially locking in the actual impeller. Maybe it's free spinning? I'm no pro but it's a simple check to just drop the lower unit.

Re: 2003 Mercury Optimax Issues [Re: Alfredo] #12330319
07/09/17 01:33 AM
07/09/17 01:33 AM
Joined: Nov 2009
Posts: 31
A
Alfredo Offline OP
Outdoorsman
Alfredo  Offline OP
Outdoorsman
A

Joined: Nov 2009
Posts: 31
I should mention that the "shop" that did the work has found a way to charge me another $550 to tell me that there is nothing wrong with it other than there is a bunch of junk in the line!

Very frustrating!!

Re: 2003 Mercury Optimax Issues [Re: Alfredo] #12330473
07/09/17 03:17 AM
07/09/17 03:17 AM
Joined: May 2003
Posts: 11,494
Littlefield Tx & Lake A. H. US...
gary purdy Offline
TFF Guru
gary purdy  Offline
TFF Guru

Joined: May 2003
Posts: 11,494
Littlefield Tx & Lake A. H. US...
Where are you located?


The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD
Previous Thread
Index
Next Thread


© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide
UBB.threads™ 7.6.2