Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
fishlovedog, TexasWomack, LMS81, dsgb, SBTNZFishing
109042 Registered Users
Top Posters
TexDawg 89788
hopalong 78895
Pilothawk 77196
John175® 69297
JDavis7873® 67392
Derek 🐝 61477
FattyMcButterpants 60906
Tritonman 58321
LoneStarSon® 54754
Mark Perry 53966
facebook
Forum Stats
109042 Members
60 Forums
831107 Topics
12101807 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12885758 - 09/03/18 12:16 PM Tilt/Trim Issue '97 Johnson 150
Fishman Mahan Offline
Outdoorsman

Registered: 04/20/12
Posts: 81
Loc: Bells, Tx.
Hello,

I recently have encountered a problem with my motors tilt/trim. When I am trimming up sometimes when I let off the button the motor still continues to trim all the way up... This causes it to get hung and of course I have to troll to the bank get out and release the hydraulic screw just enough to lower the motor to get it to go back down. (I have read Johnson are very bad about getting hung up when trimmed all the way up) I have replaced both what I call relays under the cowling but I still haven't fixed this issue. Also sometimes the motor might trim up but not down unless I move the new relays around. I have also tried putting a zip tie on each relay to make sure when running it does not lose any connection.

So here I am asking what is my next step in trouble shooting or fixing this issue.

Thank you for your time.
_________________________
"Only thing that matters is what you do from this point on"
www.xcitebaits.com
www.KistlerRods.com

Top
#12886356 - 09/03/18 09:44 PM Re: Tilt/Trim Issue '97 Johnson 150 [Re: Fishman Mahan]
PaulGrapevine Online   content
TFF Guru

Registered: 04/02/08
Posts: 11261
Loc: Grapevine, Texas
I feel like you have something wrong with a switch or your relays. A voltmeter and some trouble shooting would be my suggestion. Disconnect all but one trim switch to see if you can isolate the problem.

Top
#12891389 - 09/07/18 11:57 PM Re: Tilt/Trim Issue '97 Johnson 150 [Re: Fishman Mahan]
Fishman Mahan Offline
Outdoorsman

Registered: 04/20/12
Posts: 81
Loc: Bells, Tx.
Hey thank you for the reply! After further inspection of one of the relays I noticed a problem with it. I replaced it with a new relay and boom no issue so far!
_________________________
"Only thing that matters is what you do from this point on"
www.xcitebaits.com
www.KistlerRods.com

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide