Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
LFFM, bugs90, Cado, RobHuffster, cbFish
108443 Registered Users
Top Posters
TexDawg 89124
hopalong 78895
Pilothawk 76602
John175® 68154
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60690
Tritonman 58114
LoneStarSon® 54598
SkeeterRonnie 53487
facebook
Forum Stats
108443 Members
61 Forums
777549 Topics
10029273 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12818989 - 07/06/18 08:37 PM Help with Helix 10
mskeeter Offline
Outdoorsman

Registered: 01/05/07
Posts: 98
I have had my Helix 10 Mega for about 10 months now and love it. My issue is with the newer "snap on" plug. In rough water may unit will shut off due to the plug on the back. My other two 998's have the small bolt to secure it very snug.

Do you have any suggestions on how to help with this issue?

Thanks

Top
#12818995 - 07/06/18 08:40 PM Re: Help with Helix 10 [Re: mskeeter]
JIM SR. Offline
TFF Celebrity

Registered: 09/25/06
Posts: 7599
Loc: NRH/Fork ! GET THE NET
My Helix 7 does the same frigging thing... realmad

Top
#12819102 - 07/06/18 10:26 PM Re: Help with Helix 10 [Re: mskeeter]
mossyback75 Offline
Outdoorsman

Registered: 07/10/17
Posts: 39
Mine has the clamshell type cable tray that quick connects. Never had any problems

Top
#12819105 - 07/06/18 10:29 PM Re: Help with Helix 10 [Re: mskeeter]
CowboyVet Offline
Outdoorsman

Registered: 08/26/14
Posts: 79
Loc: Drippin Springs
My helix 10 did that as well thenI realized it was not “clicking “ in properly. It is hard to get yogr hand back there but make sure it is inserted square to the machine and the issue will be solved. So make sure it is hard wired difectly to the battery with inline 3 amp fuse.

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide