Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
DogFish9, Inglikestofish, garzas23, Yoshi13usa, F100
108901 Registered Users
Top Posters
TexDawg 89627
hopalong 78895
Pilothawk 76960
John175® 68915
JDavis7873® 67392
Derek 🐝 61294
FattyMcButterpants 60906
Tritonman 58274
LoneStarSon® 54734
Mark Perry 53670
facebook
Forum Stats
108901 Members
60 Forums
833160 Topics
12106330 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12802548 - 06/22/18 10:01 PM Electrical Issue
Grababrewski-and-Fish Offline
Outdoorsman

Registered: 06/29/09
Posts: 63
Loc: Lewisville
Please recommend someone that can fix my electrical issue on my Ranger near Lewisville. Seems like one of the breakers is out. Can't get the livewell, lights, bilgde, main graph, ect to come on. I checked all of the fuses, nothing out. Its like the power to the driver console is out.

Top
#12802662 - 06/23/18 01:04 AM Re: Electrical Issue [Re: Grababrewski-and-Fish]
WackySenko Offline
Extreme Angler

Registered: 05/14/07
Posts: 1190
Does it run on rocker switches or a board
_________________________
"Its not an addiction...its a disease! and I LIKE it! keeps my sanity in this cruel world!"

Top
#12802674 - 06/23/18 04:42 AM Re: Electrical Issue [Re: Grababrewski-and-Fish]
Tucker01 Offline
Outdoorsman

Registered: 01/22/17
Posts: 35
Do you have a main breaker back by the battery?

Top
#12802716 - 06/23/18 07:24 AM Re: Electrical Issue [Re: Tucker01]
sll Offline
Outdoorsman

Registered: 05/16/18
Posts: 109
Loc: TN
Originally Posted By: Tucker01
Do you have a main breaker back by the battery?
Check for this first. Small black box at the end of the cable that is on your battery post......some boats have it. If the plastic tab has popped out you just push it back in to reset it.

Top
#12802821 - 06/23/18 09:48 AM Re: Electrical Issue [Re: Grababrewski-and-Fish]
James P. Offline
Extreme Angler

Registered: 03/14/08
Posts: 1249
Loc: dallas tx
I had a pump going out in my livewell on my basscat. It would trip my a10 touch pad, once I turned power switch off . And back on everything worked again till I turned pump back on.

Top
#12802825 - 06/23/18 09:59 AM Re: Electrical Issue [Re: Grababrewski-and-Fish]
Grababrewski-and-Fish Offline
Outdoorsman

Registered: 06/29/09
Posts: 63
Loc: Lewisville
There are two circuit breaker switches in the battery compartment. One for main battery and one for TM. It’s a rocker switch. It either goes to the fuse block then a terminal board under the dash or vise versa. I gotta look at the wiring diagram. The terminal block isn’t getting power. Do those circuit breakers go bad?

I also gotta check to see if there is a black box with something to push in like sll mentioned.

Top
#12802836 - 06/23/18 10:13 AM Re: Electrical Issue [Re: Grababrewski-and-Fish]
RandyD Offline
Outdoorsman

Registered: 12/01/02
Posts: 44
Loc: Plano, Texas
This.... """Check for this first. Small black box MOUNTED ON TOP OF LID" ......some boats have it. If the plastic BUTTON has popped out you just push it back in to reset it"" … or,..


These breakers will go bad,... I replaced mine recently on a '96 462VS... took a little time finding an exact replacement online


Edited by RandyD (06/23/18 10:30 AM)
_________________________
Ranger Z521c / Merc 250 / Minn Kota Ultrex
GLoomis Rods / Shamano Reels,... and a whole lot of luck...



Top
#12802913 - 06/23/18 12:03 PM Re: Electrical Issue [Re: Grababrewski-and-Fish]
Grababrewski-and-Fish Offline
Outdoorsman

Registered: 06/29/09
Posts: 63
Loc: Lewisville
Confirmed bad breaker. West Marine has a replacement in stock.

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide