Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
bass&bud, MNBASSGUY, Dillon crews, Jerad, Bassrunner65
108259 Registered Users
Top Posters
TexDawg 88919
hopalong 78895
Pilothawk 76461
John175® 67870
JDavis7873® 67390
FattyMcButterpants 60885
Derek 🐝 60491
Tritonman 58054
LoneStarSon® 54529
SkeeterRonnie 53430
facebook
Forum Stats
108259 Members
60 Forums
814190 Topics
10310222 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12780070 - 06/04/18 05:12 PM bleeding air / getting tilt/trim unit to work after service
joho5 Offline
Extreme Angler

Registered: 07/03/08
Posts: 2993
Loc: Abbott, TX
Ok finally got all my seals on and figured it all out...upon reassembly, I cant get the unit to run right.

the relieve valve was open when reinstalling and when I got the unit put back on the boat, I tightened the valve and while the ram was full extended I filled up as much as I could.

it still wouldnt raise or lower, sometimes it would lower, but still havent got it to raise up.

Whats the process from a completely empty tilt and trim unit to get it to work again?

thanks

Top
#12780092 - 06/04/18 05:36 PM Re: bleeding air / getting tilt/trim unit to work after service [Re: joho5]
dobbin Offline
Pro Angler

Registered: 04/22/06
Posts: 686
Loc: hubbard
U tube is your friend....Add fluid release air....add fluid release air.... add fluid release air...Make sure the motor is up and locked as it will crash in the fluid is not full.....
_________________________
te

Top
#12780581 - 06/04/18 11:55 PM Re: bleeding air / getting tilt/trim unit to work after service [Re: joho5]
joho5 Offline
Extreme Angler

Registered: 07/03/08
Posts: 2993
Loc: Abbott, TX
I got it going. Thanks

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide