Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
south_texas_viking, William F, Khoot, Bama17, Breauxtard
108661 Registered Users
Top Posters
TexDawg 89349
hopalong 78895
Pilothawk 76777
John175® 68541
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60891
Tritonman 58183
LoneStarSon® 54677
SkeeterRonnie 53535
facebook
Forum Stats
108661 Members
61 Forums
780249 Topics
10064564 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12773651 - 05/29/18 09:12 PM Black screen on Helix 9
Decaturhammer Offline
Green Horn

Registered: 10/13/17
Posts: 9
Tried to update my Helix 9 Mega G2 for the first time. Inserted SD card for the update. Screen clicked and went black. Buttons still light up so power works. Just non responsive black screen. Disconnected unit from power from power and tried to restart. Again, buttons light up by screen stays dead and black. Any ideas?

Top
#12773761 - 05/30/18 12:16 AM Re: Black screen on Helix 9 [Re: Decaturhammer]
Bobby Milam Offline
TFF Team Angler

Registered: 07/13/14
Posts: 3553
Loc: Arlington
post in the general equipment section and Wayne will be along shortly and can probably help you out. I'd try to load an older update into it and see what happens. Not sure if you can or if restoring to factory settings would remove the update that you tried to install. Call their tech support in the morning.

Top
#12773827 - 05/30/18 06:44 AM Re: Black screen on Helix 9 [Re: Decaturhammer]
collincountytx Online   content
TFF Guru

Registered: 04/08/08
Posts: 16000
Loc: Dallas, TX
I believe you have to see the screen (run through menu options) to select factory reset.

Did you back up your waypoints/trails/etc before you inserted the update SD card? On Humminbird PC?

If yes, I'd power down the unit, go to the store and purchase a new SD card, make a new update SD card and try to load it.

SD cards can get corrupted, so to be safe, I'd either throw away the old one, or do a complete format of it to be used later.
_________________________

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide