Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
NateA114, Stickemdeep, Bezeau, NTHawg, Jacobo78
108234 Registered Users
Top Posters
TexDawg 88886
hopalong 78895
Pilothawk 76459
John175® 67844
JDavis7873® 67390
FattyMcButterpants 60883
Derek 🐝 60471
Tritonman 58049
LoneStarSon® 54519
SkeeterRonnie 53418
facebook
Forum Stats
108234 Members
60 Forums
863839 Topics
12306113 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12770883 - 05/26/18 11:34 PM Gn1 helix 10 si
jbobo Online   content
TFF Team Angler

Registered: 02/26/13
Posts: 3014
Loc: springtown,tx.
My helix 10 is about 6 months old. Non mega. The left side of my display is not reading correctly on si in any of the different screens. Transducer is mounted correctly. Di and 2d sonar work fine. Any ideas what might cause this?
_________________________
22 ft. Wellcraft Deep V CC
817-220-2312
Bridgeport/Eagle Mountain/Possum Kingdom/ Lake Texoma
www.bobosguideservice.com
www.bobosthumper.com
www.nekidtackle.com Home of the RonRig!

Top
#12770890 - 05/26/18 11:43 PM Re: Gn1 helix 10 si [Re: jbobo]
shut-up-and-fish Offline
TFF Guru

Registered: 02/08/10
Posts: 10336
Loc: Lewisville Tx.

Could be a transducer failing on you. What you are describing is usually a bad transducer that or try trimming the motor to get a clear shot across the left side. But you say you have had the unit for 6 mo. so I am leaning towards the bad transducer.
_________________________

www.shut-up-and-fish.com
It's all coming together and we have you covered @ Shut-Up-And-Fish LLC
From *Sales *Installation Services *On the Water Education & Instructional Trips
we are your One-Stop-Shop for all Humminbird MinnKota & Motorguide needs & more
972 822 9285

Top
#12770901 - 05/27/18 12:00 AM Re: Gn1 helix 10 si [Re: jbobo]
jbobo Online   content
TFF Team Angler

Registered: 02/26/13
Posts: 3014
Loc: springtown,tx.
Ok. I tried trimming the motor but it doesn’t get any better. Someone else said it might be a broken pin in the transducer plug which I haven’t checked yet. I kinda figured I’d have to replace the transducer. @&$?!”@&
Thanks David!
_________________________
22 ft. Wellcraft Deep V CC
817-220-2312
Bridgeport/Eagle Mountain/Possum Kingdom/ Lake Texoma
www.bobosguideservice.com
www.bobosthumper.com
www.nekidtackle.com Home of the RonRig!

Top
#12770934 - 05/27/18 06:07 AM Re: Gn1 helix 10 si [Re: jbobo]
Wayne P. Offline
TFF Team Angler

Registered: 11/16/10
Posts: 4081
Loc: Charlottesville, Va
Originally Posted By: jbobo
Ok. I tried trimming the motor but it doesn’t get any better. Someone else said it might be a broken pin in the transducer plug which I haven’t checked yet. I kinda figured I’d have to replace the transducer. @&$?!”@&
Thanks David!


If the transducer has failed, your warranty will replace it. Contact a Humminbird Customer Service.

BTW, the DI would not be working correctly since you would be missing half of the data to create that view.
_________________________
Humminbird Helix 12 CHIRP SI, 1198c SI, 1198c SI, ONIX 10 SI NT, Helix 7 CHIRP SI GPS G2, SOLIX 12 SI, 360, RC-1

Top
#12771120 - 05/27/18 09:53 AM Re: Gn1 helix 10 si [Re: jbobo]
jbobo Online   content
TFF Team Angler

Registered: 02/26/13
Posts: 3014
Loc: springtown,tx.
Thanks Wayne! I guess I better yank it out now so I can get the new one in by Thursday’s trip to Texoma.
_________________________
22 ft. Wellcraft Deep V CC
817-220-2312
Bridgeport/Eagle Mountain/Possum Kingdom/ Lake Texoma
www.bobosguideservice.com
www.bobosthumper.com
www.nekidtackle.com Home of the RonRig!

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide