Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jbrown18, Travisly4, Russline, Rev.,Dr.Thaddious, Robere
107989 Registered Users
Top Posters
TexDawg 88591
hopalong 78895
Pilothawk 76386
John175® 67548
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60239
Tritonman 57988
LoneStarSon® 54394
SkeeterRonnie 53365
facebook
Forum Stats
107989 Members
60 Forums
860839 Topics
12269520 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12753261 - 05/13/18 12:39 AM Impeller change gone wrong.
goodolick Online   content
Outdoorsman

Registered: 06/29/15
Posts: 73
Replaced the impeller (first time I have done one) on my Merc Alpha One Gen 2 outdrive over the weekend. Get everything put back together, and put the muffs on and fire her up. Not pumping water, shut off immediately. Positive the keyway is in there, and impeller is turned in right direction.

What could I have missed?

Also, it was winterized and the drain plugs were out of the engine prior to me doing the maintenance. Any chance engine needs to fill with water fully before it will start peeing?

Top
#12753494 - 05/13/18 10:08 AM Re: Impeller change gone wrong. [Re: goodolick]
RANGER SKI Online   content
Pro Angler

Registered: 12/18/09
Posts: 906
Loc: red oak texas
no tell tale on a inboard outboard. start up and watch hose when u rev up u will see if it picked up. if not is the metat\l tube stabbed in pump. I/o's have a thermostat and wont open right away.

Top
#12753543 - 05/13/18 11:26 AM Re: Impeller change gone wrong. [Re: goodolick]
Alumacraft 14 Offline
Outdoorsman

Registered: 02/24/06
Posts: 213
Loc: Texas
Make sure the p e e hole isn't clogged.


Edited by Alumacraft 14 (05/13/18 11:26 AM)

Top
#12753664 - 05/13/18 02:19 PM Re: Impeller change gone wrong. [Re: goodolick]
El Skeeter Online   content
Angler

Registered: 06/22/12
Posts: 487
Loc: Kissimmee,FL
If "P"hole" is clogged stick a 15" #18 ga. electrical wire in it.
Works on Yamaha.


Edited by El Skeeter (05/13/18 02:20 PM)

Top
#12753884 - 05/13/18 06:59 PM Re: Impeller change gone wrong. [Re: goodolick]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 11423
Loc: Littlefield Tx & Lake A. H. US...
Also, it was winterized and the drain plugs were out of the engine prior to me doing the maintenance. Any chance engine needs to fill with water? YES
_________________________
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

Top
#12753928 - 05/13/18 07:43 PM Re: Impeller change gone wrong. [Re: gary purdy]
goodolick Online   content
Outdoorsman

Registered: 06/29/15
Posts: 73
Originally Posted By: gary purdy
Also, it was winterized and the drain plugs were out of the engine prior to me doing the maintenance. Any chance engine needs to fill with water? YES


So just let it run for 10 seconds or so at a time till it starts pumping out the exhaust to verify job was done correct?

Top
#12754105 - 05/13/18 10:54 PM Re: Impeller change gone wrong. [Re: goodolick]
RANGER SKI Online   content
Pro Angler

Registered: 12/18/09
Posts: 906
Loc: red oak texas
engine does not need to be primed just run it a while and make sure water is coming out of exhaust do like goodolick days

Top
#12754111 - 05/13/18 11:07 PM Re: Impeller change gone wrong. [Re: RANGER SKI]
goodolick Online   content
Outdoorsman

Registered: 06/29/15
Posts: 73
Dont want to run it too long without proper cooling, hence my concern.

Top
#12754689 - 05/14/18 11:26 AM Re: Impeller change gone wrong. [Re: goodolick]
TXMako2201 Offline
Outdoorsman

Registered: 10/26/16
Posts: 105
keep an eye on engine temp and run it. could take a couple minutes to make its way through

Top
#12755710 - 05/14/18 09:36 PM Re: Impeller change gone wrong. [Re: goodolick]
goodolick Online   content
Outdoorsman

Registered: 06/29/15
Posts: 73
Cant really say what went wrong the first time, but, she is peeing like a champ now. Still never started peeing, and started getting hot. Took apart again. Some blades on impeller were turned right, some were turned left. Put them all in the right direction, put back together, and it is good to go.

Thanks for tips TFFRs.


BTW, even though water was out of the engine, after second assembly, it started peeing immediately.

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide