Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
axlaws@yahoo.com, ol' fart, jrossi12, skeet15, FX21
108424 Registered Users
Top Posters
TexDawg 89114
hopalong 78895
Pilothawk 76596
John175® 68121
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60670
Tritonman 58110
LoneStarSon® 54589
SkeeterRonnie 53483
facebook
Forum Stats
108424 Members
61 Forums
777366 Topics
10026744 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12743849 - 05/04/18 08:18 PM Power Pole Install Problems?
BigTxBassMan Offline
Outdoorsman

Registered: 05/12/09
Posts: 69
Loc: Livingston, Texas
I just bought a used set of power poles. What do I need to look out for on the install? I've got an old '98 Ranger R91 with no jack plate. Is the install difficult?

Top
#12744138 - 05/05/18 07:12 AM Re: Power Pole Install Problems? [Re: BigTxBassMan]
dimitri Offline
Extreme Angler

Registered: 08/12/09
Posts: 2222
Loc: Arlington TX
easy to install IF you have all the parts. lay out what you have and go to pp website to see what is included when bought new. if you do not have everything give them a call and they will ship you whatever is missing. i have personally installed several sets on my boats and it’s super easy.

fyi: not having a jackplate definitely make it more difficult because you have to remove transom bolts that hold the engine to sandwich the bracket between them. unless they came out with a bracket recently that bolts on after the engine. look on youtube for install videos

Top
#12744584 - 05/05/18 05:19 PM Re: Power Pole Install Problems? [Re: BigTxBassMan]
Clark3 Offline
Pro Angler

Registered: 01/22/12
Posts: 970
Loc: Haslet, TX
With no jack plate the only way i would install would be the sand which plate mount which you losten fhe outboard and slide in the mount and it sandwiches between transom and motor.

Easy install with it, took me 2-3 hours to install 2 on my old hawk with no jackplate
_________________________

Top
#12744625 - 05/05/18 05:52 PM Re: Power Pole Install Problems? [Re: Clark3]
BigTxBassMan Offline
Outdoorsman

Registered: 05/12/09
Posts: 69
Loc: Livingston, Texas
How did you support the motor when you took the mounting bolts out?

Top
#12744747 - 05/05/18 07:48 PM Re: Power Pole Install Problems? [Re: BigTxBassMan]
Clark3 Offline
Pro Angler

Registered: 01/22/12
Posts: 970
Loc: Haslet, TX
I made A thread way back when let me see if I can Find it.

Bascially, I clamped 2 2x4’s around the skeg and then lowered the trim on a block of wood to take the pressure off. Loosened the top 2 bolts and slid the plates in and slid the bolts in. Then loosened the bottom bolts and slid the rest of the plate in the. Torqued everything back up
_________________________

Top
#12744862 - 05/05/18 09:38 PM Re: Power Pole Install Problems? [Re: Clark3]
BigTxBassMan Offline
Outdoorsman

Registered: 05/12/09
Posts: 69
Loc: Livingston, Texas
Thanks!! That makes sense and sounds easy enough. I was afraid I was going to have to find an engine lift or pull it under the oak tree out back and get out the come-a-long. I like your method a lot better!!

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide