Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
dbell47, AJP5, Spencer88, Bcbbs, Njsowden
108464 Registered Users
Top Posters
TexDawg 89134
hopalong 78895
Pilothawk 76607
John175® 68191
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60702
Tritonman 58123
LoneStarSon® 54608
SkeeterRonnie 53490
facebook
Forum Stats
108464 Members
61 Forums
827774 Topics
12032418 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12707508 - 04/07/18 07:22 PM Power issue
SkeeterB Offline
Angler

Registered: 07/02/06
Posts: 292
Loc: Grapevine
Can anyone tell me why my graphs were turning off in rough water today? They also blink on and off when I start my motor. It’s started early this morning and seemed to go away as the day went on.

Top
#12707526 - 04/07/18 07:32 PM Re: Power issue [Re: SkeeterB]
tmd11111 Offline
Pro Angler

Registered: 04/30/17
Posts: 850
Loc: San Angelo
Bad connection or loose ground.

Top
#12707802 - 04/08/18 06:18 AM Re: Power issue [Re: SkeeterB]
basshc Online   content
Outdoorsman

Registered: 04/25/10
Posts: 161
Had old HB on big water had internal problem would turn off when it got bad.

Top
#12707824 - 04/08/18 07:06 AM Re: Power issue [Re: tmd11111]
Pintail711 Online   content
Extreme Angler

Registered: 08/11/15
Posts: 2501
Loc: Longview, Tx
Originally Posted By: tmd11111
Bad connection or loose ground.


This. Take some contact cleaner and spray the connections. Then take a dab of dielectric grease and put on all connections... battery terminals, transducer connections, head unit power etc.

Top
#12707833 - 04/08/18 07:25 AM Re: Power issue [Re: SkeeterB]
ChuChu1 Online   content
TFF Team Angler

Registered: 03/08/10
Posts: 3377
Loc: Gonzales, Tx
The blinking off when starting the outboard is from voltage dropping below minimum required to operate the unit. Check ALL connections and have the battery checked.
_________________________
Snowflakes and entitled brats will be the doom of America!



Top
#12707862 - 04/08/18 08:09 AM Re: Power issue [Re: SkeeterB]
Txmedic033 Offline
TFF Team Angler

Registered: 08/13/13
Posts: 4609
Loc: Longview, Tx
I had issues with mine and couldn't find any bad connections. I pulled new wires and it solved the problem. I had a weak spot in my wires that I couldn't even see.

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide