Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
dbell47, AJP5, Spencer88, Bcbbs, Njsowden
108464 Registered Users
Top Posters
TexDawg 89131
hopalong 78895
Pilothawk 76607
John175® 68191
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60702
Tritonman 58123
LoneStarSon® 54606
SkeeterRonnie 53489
facebook
Forum Stats
108464 Members
61 Forums
827731 Topics
12031958 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12689921 - 03/26/18 01:24 PM helix 7 gps
rmorris Offline
Outdoorsman

Registered: 08/28/07
Posts: 96
I bought a new helix 7 last August. I finally got the lakemaster card for right after the new year started. The gps takes forever to find me. Sometimes I have to take the card out and let the maps that are already on unit find me. I then put the card back in and it goes over to the lakemaster card. Saturday on Cypress it finally found me but the screen was black. It followed me all day with a black screen and a red line all over it. Can anybody give me any suggestions on what could be wrong or how to fix this problem. Thanks in advance for any help with this matter.

Top
#12689928 - 03/26/18 01:29 PM Re: helix 7 gps [Re: rmorris]
Bobby Milam Online   content
TFF Team Angler

Registered: 07/13/14
Posts: 3516
Loc: Arlington
Remove the card and blow into slot. Check contacts on card to see if they are clean. If not use an eraser to clean. Look at settings and see if it is turned on auto for selecting map card

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide